Bug 996656 - printing fails in function cups_job_submit
printing fails in function cups_job_submit
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba3x (Show other bugs)
5.9
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Andreas Schneider
qe-baseos-daemons
:
Depends On:
Blocks: 1049888
  Show dependency treegraph
 
Reported: 2013-08-13 11:21 EDT by Need Real Name
Modified: 2014-09-15 20:26 EDT (History)
6 users (show)

See Also:
Fixed In Version: samba3x-3.6.22-0.1.el5
Doc Type: Bug Fix
Doc Text:
When the smbd server daemon executed spooling for a print action, it previously did not include the job ID in the generated spool-file path. As a consequence, the spool check could not validate the spool-file's existence, and the printing thus failed. With this update, smbd includes jobid in the spool-file path and parsing the file name succeeds. As a result, printing via Samba now works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:26:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 8719 None None None Never

  None (edit)
Description Need Real Name 2013-08-13 11:21:33 EDT
Description of problem: Print data received from a PC via SAMBA as \\server\printershare fails to be submitted to CUPS and subsequently fails to print. 


Version-Release number of selected component (if applicable): samba3x-3.6.6-0.129.el5


How reproducible: Every time.


Steps to Reproduce:
1. Install samba3x-3.6.6-0.129.el5 packages
2. Share a printer queue to PCs via SAMBA
3. Print to it from a PC

Actual results: Nothing prints, errors in SAMBA logs
/var/log/samba/{computer name}.log:

{computer name}.log:[2013/01/18 15:29:32.934415, 0] printing/print_cups.c:940(cups_job_submit)
{computer name}.log: cups_job_submit: failed to parse jobid from name /var/spool/samba/smbprn..VkNm54


Expected results: Ink on paper :)


Additional info: This is a SAMBA bug and they corrected it over a year ago https://bugzilla.samba.org/show_bug.cgi?id=8719
Comment 2 RHEL Product and Program Management 2014-01-22 11:26:58 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 6 errata-xmlrpc 2014-09-15 20:26:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1212.html

Note You need to log in before you can comment on or make changes to this bug.