Bug 996720 - Upgrade to 0.5.21
Upgrade to 0.5.21
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-pbr (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 15:26 EDT by Matthew Farrellee
Modified: 2013-08-26 04:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 04:54:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2013-08-13 15:26:06 EDT
OpenStack components, including Savanna, are moving to pbr. Savanna is going to require pbr>=0.5.21.

Please upgrade F19+ to 0.5.21+.
Comment 1 Matthias Runge 2013-08-13 16:40:21 EDT
Rawhide has already pbr-0.5.21. IMHO for f19 it's forbidden by policy:
http://fedoraproject.org/wiki/Updates_Policy#Stable_Releases
especially since pbr was really good in introducing new features or to change them even in minor releases.

Do you really need it, esp. as runtime requirement? It is clearly possible to build in rawhide, like we do for all other OpenStack components.
Comment 2 Matthew Farrellee 2013-08-17 10:00:23 EDT
I can't speak to the stability / instability of pbr and its backward compatibility. I would hope it has good compatibility, but that may not be the case.

FYI - https://github.com/openstack-dev/pbr/compare/0.5.19...0.5.21

I'm planning to try 0.5.19 w/ a sed -i edit when the pbr changes are committed to Savanna.

Feel free to close this out, but I may re-open it if I can't workaround in the spec.

Note You need to log in before you can comment on or make changes to this bug.