Bug 996740 - no Full RELRO
no Full RELRO
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 16:44 EDT by Harald Reindl
Modified: 2013-10-14 13:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: cups-1.6.4-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 03:12:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-08-13 16:44:52 EDT
http://fedoraproject.org/wiki/Packaging:Guidelines#PIE

"Immediate binding: no, not found!"
http://tk-blog.blogspot.co.at/2009/02/relro-not-so-well-known-memory.html


[root@srv-rhsoft:~]$ hardening-check /usr/sbin/cupsd
/usr/sbin/cupsd:
 Position Independent Executable: yes
 Stack protected: yes
 Fortify Source functions: yes (some protected functions found)
 Read-only relocations: yes
 Immediate binding: no, not found!
Comment 1 Tim Waugh 2013-08-15 08:08:15 EDT
Fixed in:
 cups-1.6.3-6.fc19
 cups-1.7-0.24.rc1.fc20
Comment 2 Harald Reindl 2013-08-15 08:19:00 EDT
when do maintainers realize that the last thing a reporter want to hear if he submits a bug for F18 "fixed in F19 and F20" - damned the reporter is interested in this fix and can hardly use a package from F+1 to test and verify

so *the first* build on koji has to be the Fedora version for which the bug is reported
Comment 3 Harald Reindl 2013-08-18 08:48:12 EDT
what about F18

hence i do not need CUPS at all except 5 times a year, it runs only because the stupidity fire up all sort of services like cups/avahi after graphical Login via dbus and masking results in spitting /var/log/messages full because failed starts

so if there are unused processes on my system they have to be hardened and by the way would it be a godd idea if maintainers read the packaging guidelines and verify their builds *before* release
Comment 4 Harald Reindl 2013-09-19 07:43:01 EDT
and where is the F19 package?

in the meantime upgraded to Fedora 19
updates-testing enabled as all the time
no cups-1.6.3-6.fc19 package

cupsd  23452 Partial RELRO     Canary found           NX enabled    PIE enabled 
cups-1.6.3-4.fc19.x86_64
Comment 5 Fedora Update System 2013-10-11 07:49:59 EDT
cups-1.6.4-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cups-1.6.4-2.fc19
Comment 6 Fedora Update System 2013-10-11 19:58:56 EDT
Package cups-1.6.4-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-1.6.4-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18910/cups-1.6.4-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-10-14 03:12:44 EDT
cups-1.6.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-10-14 13:16:33 EDT
cups-1.6.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.