Bug 996767 - [HHH-8440] Add SQLServer2012Dialect in Hibernate
[HHH-8440] Add SQLServer2012Dialect in Hibernate
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity low
: DR6
: EAP 6.3.0
Assigned To: Brett Meyer
Zbyněk Roubalík
Russell Dickenson
:
Depends On:
Blocks: 1010467 1029937 1073085
  Show dependency treegraph
 
Reported: 2013-08-13 18:13 EDT by Ricardo Martinelli de Oliveira
Modified: 2015-09-01 00:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The Hibernate component in JBoss EAP 6 has been updated to provided support for features introduced in MySQL 2012. Users can now utilize features such as SEQUENCE object creation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:26:27 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricardo Martinelli de Oliveira 2013-08-13 18:13:05 EDT
Customer is planning to use MS SQL Server 2012 in their new projects and according to EAP 6.1.0 supported configurations we certify this database. However, new features in that version (like the SEQUENCE object creation) are not added in Hibernate.
Comment 1 Brett Meyer 2013-08-13 22:11:48 EDT
https://hibernate.atlassian.net/browse/HHH-8440
Comment 2 Brett Meyer 2013-09-05 15:58:22 EDT
This is not currently in Hibernate ORM's build (4.2.5.Final) for EAP 6.2.0 ER1.  The RFE JIRA was just opened: https://issues.jboss.org/browse/PRODMGT-539

How do we handle sence the 6.2.0 component upgrade freeze is past?  I'd prefer to defer until 6.3.0, unless other Hibernate issues are needed in a 6.2.0 ER build.  Happy to create one-offs as necessary.
Comment 3 Brett Meyer 2013-09-10 17:52:24 EDT
Setting release target as 6.3.0 since 6.2.0's feature freeze is past.
Comment 4 Brett Meyer 2013-09-25 11:53:38 EDT
Actually, this will go into EAP 6.2.0 ER4's upgrade to Hibernate ORM 4.2.6.Final in 1010467.
Comment 8 Dave Stahl 2013-11-13 13:47:49 EST
This was originally planned to go into hibernate 4.2.6.Final, but was inadvertently left out of the release.  As the deadline for 6.2.CR1 has already passed, this seems unlikely to make it into 6.2.
Comment 9 Brett Meyer 2014-01-30 13:27:01 EST
Will be included in the Hibernate ORM component upgrade for EAP 6.3
Comment 10 Jan Martiska 2014-04-15 06:54:45 EDT
Verified in EAP 6.3.0.ER1. QA will now run the testsuite with the new dialect instead of falling back to SQLServer2008Dialect.

Note You need to log in before you can comment on or make changes to this bug.