Bug 996808 - need initialisation on startup without requiring someone to login
need initialisation on startup without requiring someone to login
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER6
: ---
Assigned To: Mauricio Salatino
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 22:31 EDT by Hisao Furuichi
Modified: 2013-08-15 07:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 996806
Environment:
Last Closed: 2013-08-15 07:56:31 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hisao Furuichi 2013-08-13 22:31:48 EDT
+++ This bug was initially created as a clone of Bug #996806 +++

Description of problem:
jBPM-console doesn't load a ksession object until user access to jBPM-console.
Since ksession should be activated for timer events, user should log on to jBPM-console after booting up BRMS to make sure that timer event is invoked and process instance is operated as it is. 

Steps to Reproduce:
1: Start a process instance that is waiting on a 1 minute timer to expire via the business central website. 
2: Shutdown the server and start it up again. Startup is taking 3.5 minutes so the timer has expired by this time.

Actual results:
Timer is not expired without accessing to jBPM-Console

Expected results:
Timer is expired without accessing to jBPM-Console
Comment 1 Hisao Furuichi 2013-08-13 22:50:32 EDT
I'm not sure this issue happens with BPMN 6 or not. If the issue is not happen with BPMN 6, please reject this ticket.

Thx
Comment 2 Mauricio Salatino 2013-08-15 04:40:28 EDT
this is already supported in version 6.
You can close this bug, because it is already fixed
Comment 3 Hisao Furuichi 2013-08-15 07:56:31 EDT
Hello.
Thx for you check. I close this ticket now.

Note You need to log in before you can comment on or make changes to this bug.