Bug 996857 - reverse arithmetic evaluation
reverse arithmetic evaluation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rsyslog7 (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Heinrich
Dalibor Pospíšil
:
Depends On:
Blocks: 1030206 1108066
  Show dependency treegraph
 
Reported: 2013-08-14 03:37 EDT by Bala.FA
Modified: 2015-11-22 21:57 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1108066 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:30:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The fix is attached (1.13 KB, patch)
2013-08-14 03:44 EDT, Bala.FA
no flags Details | Diff

  None (edit)
Description Bala.FA 2013-08-14 03:37:50 EDT
Description of problem:

When arithmetic operation is done in configuration file like

if $msgid % 10 == 0 then /var/log/event.log

the evaluation happens in reverse ie 10 % $msgid, which happens to be wrong result/behavior.


Version-Release number of selected component (if applicable):
v5.8.10
Comment 2 Bala.FA 2013-08-14 03:44:16 EDT
Created attachment 786420 [details]
The fix is attached
Comment 3 RHEL Product and Program Management 2013-10-13 22:44:42 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Tomas Heinrich 2014-03-20 18:17:05 EDT
This is to be solved either by the rebase to v7 (bug 869600) or additional patch.
Comment 13 errata-xmlrpc 2014-10-14 03:30:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1540.html

Note You need to log in before you can comment on or make changes to this bug.