Bug 996874 - Cannot set messageType for variable in BPEL Process editor
Cannot set messageType for variable in BPEL Process editor
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: BPEL editor (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER2
: 6.0.0
Assigned To: Jiri Sedlacek
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 04:27 EDT by Jiri Sedlacek
Modified: 2015-08-02 19:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
configuration description (803.84 KB, text/plain)
2013-08-26 10:27 EDT, Jiri Sedlacek
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBTIS-149 Major Closed update BPEL in JBTIS 4.1.2 to include latest Eclipse BPEL 1.0.3 2015-02-11 02:38:32 EST

  None (edit)
Description Jiri Sedlacek 2013-08-14 04:27:38 EDT
After inserting new component with BPEL implementation, process is created with request/response variables according to WSDL interface, but variables are set as element, it's not possible to change it to 'messageType' in editor or choose different type.
Comment 1 Robert (Bob) Brodt 2013-08-15 14:42:33 EDT
I'm not sure what you are trying to do. Is it possible that you are attempting to change the definition in the WSDL? If so, this should be done with the WSDL editor.

Can you please provide a sample process and WSDL file that illustrates the issue?
Comment 2 Jiri Sedlacek 2013-08-16 02:20:54 EDT
No Rob, I'm trying to change variable properties in BPEL editor. 

My steps:
1. Created new switchyard project
2. I prepared WSDL file before, so I copied it to the project src/main/resources dir.
3. Placed new BPEL implementation into switchyard composite in switchyard editor - choosed where to save process file and used the prepared WSDL file.
4. Opened process by double-clicking on it's image in switchyard editor
5. Now I choosed variable in variable lists and clicked on it
6. I would like to modify the variable to have 'message type' attribute instead of 'element type' and to choose this file in editor. Clicking on browse (highlighted on attached screenshot) does nothing.

If I try to use process with variables defined as 'element type', it cannot be deployed, so I need to set it as 'message type'

I'm using: 
- JBDS 7.0.0.GA
- Switchyard plugins version is 1.0.0.v20130722-1948-H360-CI
- JBoss BPEL Editor version 1.2.1.Final-v20130225-1413-B89
Comment 3 Robert (Bob) Brodt 2013-08-16 04:17:55 EDT
Can you please attach the bpel and wsdl files that you're working with? Also, a screenshot would be helpful - there is nothing attached to this BZ.
Comment 4 Robert (Bob) Brodt 2013-08-16 05:39:24 EDT
OK, it looks like the "Variable Type Selection" dialog was not opening because of a Null Pointer Exception during its creation. I fixed the NPE and a new build is available here:

http://download.eclipse.org/bpel/site/1.0.3

Please refresh the JBoss aggregate site with these new artifacts.

Thanks!
Comment 5 Nick Boldt 2013-08-19 11:04:50 EDT
Link to JBTIS-149.
Comment 6 JBoss JIRA Server 2013-08-19 11:17:30 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBTIS-149

BPEL mirrored: http://download.jboss.org/jbosstools/updates/requirements/bpel/1.0.3.v20130816-0911-H221-CI/

Next step... update JBTIS TP, rebuild JBTIS TP, rebuild JBoss BPEL project...
Comment 7 JBoss JIRA Server 2013-08-19 11:43:12 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBTIS-149

Update JBTIS TP in 41x (master) branch to include new BPEL 1.0.3 2013/08/16 H221 CI build: https://github.com/jbosstools/jbosstools-integration-stack/pull/78 - [~pleacu] please approve and push.
Comment 8 JBoss JIRA Server 2013-08-19 12:05:54 EDT
Paul Leacu <pleacu@redhat.com> made a comment on jira JBTIS-149

PR processed.
Comment 9 JBoss JIRA Server 2013-08-19 14:56:15 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBTIS-149

[~bbrodt]: When new JBTIS TP 4.1.2.Final [1] is released [2] later today, please apply this PR [3] so we can include the newer Eclipse BPEL 1.0.3 bits in the JBoss BPEL build when respun [4].

[1] https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/DevStudio/view/JBTIS/job/JBTIS-target-platform/138/console

[2] https://repository.jboss.org/nexus/content/repositories/releases/org/jboss/tools/integration-stack/target-platform/

[3] https://github.com/jbosstools/jbosstools-bpel/pull/15

[4] https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/DevStudio/view/JBTIS/job/JBTIS-bpel-4.1.x/ >=1017
Comment 10 JBoss JIRA Server 2013-08-19 15:35:42 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBTIS-149

[~bbrodt]: A new JBTIS TP 4.1.2.Final [1] is now released [2].

[1] https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/DevStudio/view/JBTIS/job/JBTIS-target-platform/138/console

[2] https://repository.jboss.org/nexus/content/repositories/releases/org/jboss/tools/integration-stack/target-platform/4.1.2.Final/

Please apply this PR [3] so we can include the newer Eclipse BPEL 1.0.3 bits in the JBoss BPEL build when respun [4].

[3] https://github.com/jbosstools/jbosstools-bpel/pull/15

[4] https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/DevStudio/view/JBTIS/job/JBTIS-bpel-4.1.x/ >=1018
Comment 11 JBoss JIRA Server 2013-08-20 12:00:46 EDT
Robert (Bob) Brodt <bbrodt@redhat.com> made a comment on jira JBTIS-149

Done. Thanks Nick!
Comment 12 JBoss JIRA Server 2013-08-20 13:28:19 EDT
Paul Leacu <pleacu@redhat.com> made a comment on jira JBTIS-149

pull requests merged.
Comment 13 JBoss JIRA Server 2013-08-20 17:15:14 EDT
Nick Boldt <nboldt@redhat.com> updated the status of jira JBTIS-149 to Reopened
Comment 14 JBoss JIRA Server 2013-08-20 17:15:14 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBTIS-149

Oops, forgot to apply the PR in the 4.1.x branch too. My bad, here's a fresh one:

https://github.com/jbosstools/jbosstools-bpel/pull/16

[~bbrodt], please apply in the 4.1.x branch.
Comment 15 JBoss JIRA Server 2013-08-20 17:20:01 EDT
Robert (Bob) Brodt <bbrodt@redhat.com> made a comment on jira JBTIS-149

Okey dokey.
Comment 16 JBoss JIRA Server 2013-08-21 10:43:34 EDT
Paul Leacu <pleacu@redhat.com> made a comment on jira JBTIS-149

[~nickboldt] - you're still planning on a BPEL change to the composites in JBTIS, yes?
Comment 17 JBoss JIRA Server 2013-08-21 12:35:21 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBTIS-149

Respinning the BPEL 1.2.100 dev milestone promote:

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/jbosstools-promote/ =90

Respinning the JBTIS 4.1.2 aggregation to pick up the newer BPEL 1.2.100 dev milestone:

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/JBTIS-aggregate-disc/ >=110
Comment 18 JBoss JIRA Server 2013-08-22 09:03:57 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBTIS-149

Just realized that the JBTIS aggregate site [1] does not contain the org.eclipse.bpel features [2]. 

[1] http://download.jboss.org/jbosstools/builds/staging/JBTIS-aggregate-disc/all/repo/ (build B110)
[2] http://download.jboss.org/jbosstools/updates/development/kepler/integration-stack/bpel/1.2.100.Final/ (build B1019)

Which means the only way to install them is from the JBTIS Central Discovery site which we will finish setting up today.
Comment 19 JBoss JIRA Server 2013-08-23 13:27:47 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBTIS-149

http://download.jboss.org/jbosstools/updates/integration/kepler/integration-stack/aggregate/4.1.2/ now finally contains the updated BPEL (build B1019).

Discovery site is here: 

http://download.jboss.org/jbosstools/discovery/integration/integration-stack/4.1.2/

So to install via Help > Install, you need to add three URLs in this order:

* http://download.jboss.org/jbosstools/updates/stable/kepler/
* http://download.jboss.org/jbosstools/targetplatforms/jbtistarget/4.1.2.Final/REPO/
* http://download.jboss.org/jbosstools/updates/integration/kepler/integration-stack/aggregate/4.1.2/

Then install from the last one.

Or, to install from Central:

a) installing JBT into Eclipse 4.3 from http://download.jboss.org/jbosstools/updates/stable/kepler/ or Eclipse Marketplace. Shut down.
b) restart Eclipse using this commandline option (or add these -D flags into your eclipse.ini file):

{code:title=pass in via commandline}
./eclipse -vmargs -Djboss.discovery.directory.url=http://download.jboss.org/jbosstools/discovery/integration/integration-stack/4.1.2/jbosstools-integration-stack-directory.xml -Djboss.discovery.site.url=http://download.jboss.org/jbosstools/discovery/integration/integration-stack/4.1.2/ 
{code}
or
{code:title=add to eclipse.ini}
-Djboss.discovery.directory.url=http://download.jboss.org/jbosstools/discovery/integration/integration-stack/4.1.2/jbosstools-integration-stack-directory.xml
-Djboss.discovery.site.url=http://download.jboss.org/jbosstools/discovery/integration/integration-stack/4.1.2/
{code}
Comment 20 JBoss JIRA Server 2013-08-23 13:28:35 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBTIS-149

http://download.jboss.org/jbosstools/updates/integration/kepler/integration-stack/aggregate/4.1.2/ now finally contains the updated BPEL (build B1019).

Discovery site is here: 

http://download.jboss.org/jbosstools/discovery/integration/integration-stack/4.1.2/

So to install via Help > Install, you need to add three URLs in this order:

* http://download.jboss.org/jbosstools/updates/stable/kepler/
* http://download.jboss.org/jbosstools/targetplatforms/jbtistarget/4.1.2.Final/REPO/
* http://download.jboss.org/jbosstools/updates/integration/kepler/integration-stack/aggregate/4.1.2/

Then install from the last one.

Or, to install from Central:

a) install JBT 4.1 into Eclipse 4.3 from http://download.jboss.org/jbosstools/updates/stable/kepler/ or from Eclipse Marketplace. Rather than restarting when prompted, simply shut down Eclipse entirely.

b) restart Eclipse using this commandline option (or add these -D flags into your eclipse.ini file):

{code:title=pass in via commandline}
./eclipse -vmargs -Djboss.discovery.directory.url=http://download.jboss.org/jbosstools/discovery/integration/integration-stack/4.1.2/jbosstools-integration-stack-directory.xml -Djboss.discovery.site.url=http://download.jboss.org/jbosstools/discovery/integration/integration-stack/4.1.2/ 
{code}
or
{code:title=add to eclipse.ini}
-Djboss.discovery.directory.url=http://download.jboss.org/jbosstools/discovery/integration/integration-stack/4.1.2/jbosstools-integration-stack-directory.xml
-Djboss.discovery.site.url=http://download.jboss.org/jbosstools/discovery/integration/integration-stack/4.1.2/
{code}
Comment 21 Jiri Sedlacek 2013-08-26 10:27:29 EDT
Created attachment 790535 [details]
configuration description
Comment 22 Jiri Sedlacek 2013-08-26 10:28:58 EDT
I can see the problem even after update, output from installation details dialog is attached.
Comment 23 Nick Boldt 2013-08-26 12:18:20 EDT
The important part in your log is this, which shows you DID in fact install the newer version of Eclipse BPEL 1.0.3:

org.jboss.tools.bpel.feature (1.2.100.Final-v20130821-0236-B1019) "BPEL Editor"

org.eclipse.bpel.apache.ode.deploy.model (1.0.3.v20130816-0911-H221-CI) "EMF Model for ODE Deployment Descriptor" [Starting]
org.eclipse.bpel.apache.ode.deploy.ui (1.0.3.v20130816-0911-H221-CI) "UI for ODE Deployment Descriptor" [Starting]
org.eclipse.bpel.apache.ode.runtime (1.0.3.v20130816-0911-H221-CI) "Apache ODE Runtime Adapter" [Starting]
org.eclipse.bpel.common.model (1.0.3.v20130816-0911-H221-CI) "BPEL Common Model" [Active]
org.eclipse.bpel.common.ui (1.0.3.v20130816-0911-H221-CI) "BPEL Common UI" [Active]
org.eclipse.bpel.common.wsdl (1.0.3.v20130816-0911-H221-CI) "SOA Commons for WSDL and XML Schemas" [Starting]
org.eclipse.bpel.help (1.0.3.v20130816-0911-H221-CI) "BPEL Help" [Starting]
org.eclipse.bpel.cheatsheet (1.0.3.v20130816-0911-H221-CI) "BPEL Cheatsheet" [Starting]
org.eclipse.bpel.model (1.0.3.v20130816-0911-H221-CI) "BPEL Model" [Active]
org.eclipse.bpel.runtimes (1.0.3.v20130816-0911-H221-CI) "Eclipse BPEL Designer Runtimes" [Active]
org.eclipse.bpel.ui (1.0.3.v20130816-0911-H221-CI) "BPEL Editor" [Active]
org.eclipse.bpel.validator (1.0.3.v20130816-0911-H221-CI) "BPEL Validator Plug-in" [Active]
org.eclipse.bpel.wsil.model (1.0.3.v20130816-0911-H221-CI) "WSIL Model" [Active]
org.eclipse.bpel.xpath10 (1.0.3.v20130816-0911-H221-CI) "XPath Parser 1.0" [Resolved]

So... if the fix from @Bob Brodt didn't fix the problem, we need to get another fix into http://download.eclipse.org/bpel/site/1.0.3 and go through this song-and-dance again. :(

@Bob, can you verify?
Comment 24 JBoss JIRA Server 2013-08-26 12:19:37 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBTIS-149

Nick Boldt <nboldt@redhat.com> made a comment on [bug 996874|https://bugzilla.redhat.com/show_bug.cgi?id=996874]

The important part in your log is this, which shows you DID in fact install the newer version of Eclipse BPEL 1.0.3:

{code}
org.jboss.tools.bpel.feature (1.2.100.Final-v20130821-0236-B1019) "BPEL Editor"

org.eclipse.bpel.apache.ode.deploy.model (1.0.3.v20130816-0911-H221-CI) "EMF Model for ODE Deployment Descriptor" [Starting]
org.eclipse.bpel.apache.ode.deploy.ui (1.0.3.v20130816-0911-H221-CI) "UI for ODE Deployment Descriptor" [Starting]
org.eclipse.bpel.apache.ode.runtime (1.0.3.v20130816-0911-H221-CI) "Apache ODE Runtime Adapter" [Starting]
org.eclipse.bpel.common.model (1.0.3.v20130816-0911-H221-CI) "BPEL Common Model" [Active]
org.eclipse.bpel.common.ui (1.0.3.v20130816-0911-H221-CI) "BPEL Common UI" [Active]
org.eclipse.bpel.common.wsdl (1.0.3.v20130816-0911-H221-CI) "SOA Commons for WSDL and XML Schemas" [Starting]
org.eclipse.bpel.help (1.0.3.v20130816-0911-H221-CI) "BPEL Help" [Starting]
org.eclipse.bpel.cheatsheet (1.0.3.v20130816-0911-H221-CI) "BPEL Cheatsheet" [Starting]
org.eclipse.bpel.model (1.0.3.v20130816-0911-H221-CI) "BPEL Model" [Active]
org.eclipse.bpel.runtimes (1.0.3.v20130816-0911-H221-CI) "Eclipse BPEL Designer Runtimes" [Active]
org.eclipse.bpel.ui (1.0.3.v20130816-0911-H221-CI) "BPEL Editor" [Active]
org.eclipse.bpel.validator (1.0.3.v20130816-0911-H221-CI) "BPEL Validator Plug-in" [Active]
org.eclipse.bpel.wsil.model (1.0.3.v20130816-0911-H221-CI) "WSIL Model" [Active]
org.eclipse.bpel.xpath10 (1.0.3.v20130816-0911-H221-CI) "XPath Parser 1.0" [Resolved]
{code}

So... if the fix from [~bbrodt] didn't fix the problem, we need to get another fix into http://download.eclipse.org/bpel/site/1.0.3 and go through this song-and-dance again. :(

[~bbrodt], can you verify?
Comment 25 JBoss JIRA Server 2013-08-26 18:00:12 EDT
Robert (Bob) Brodt <bbrodt@redhat.com> made a comment on jira JBTIS-149

I apologize - I forgot that there are two code branches at eclipse.org and I made the fix to one but not the other. I've republished the builds. Nick or Paul, can you please rebuild the JBT update site with the new build - it should be version 1.0.3.v20130816-0854-CI.

Sorry for the confusion :(
Comment 26 JBoss JIRA Server 2013-08-27 16:19:32 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBTIS-149

[~bbrodt] Are you sure you want an older version? Previously tested 1.0.3.v20130816-0911-H221-CI. Also, why does this respin lack a build number (B221), yet override the previous site with an older timestamped version?

[~jsedlacek] Can you install BPEL 1.0.3.v20130816-0854-CI from http://download.eclipse.org/bpel/site/1.0.3/ on top of your existing install, and see if the problem is fixed? That way we can verify this is the correct solution before we respin the JBTIS TP, respin JBoss BPEL, publish it, then respin JBTIS.
Comment 27 JBoss JIRA Server 2013-08-27 16:32:47 EDT
Robert (Bob) Brodt <bbrodt@redhat.com> made a comment on jira JBTIS-149

Yes yes, this is the right build number. The previous one was for helios and earlier but somehow got copied to the juno update site. I built the juno artifacts before heilos, that's why the earlier timestamp. Besides that, the helios artifacts did not include the fix because, as I said earlier, I forgot there are two code branches: one for helios and one for juno.

Long story short,  http://download.eclipse.org/bpel/site/1.0.3 is for juno and beyond;  http://download.eclipse.org/bpel/site-helios/1.0.3 is for helios and prior; both update sites have the fix for this JIRA.

<whew!>
Comment 28 Nick Boldt 2013-08-27 17:33:38 EDT
Does that mean your stuff isn't being built/tested/installed with Kepler? JBTIS 4.1 is targetting Kepler (Eclipse 4.3), not anything earlier.

(Also, what about Indigo? Did you skip from Helios to Juno? Will your next release target Luna? *confused*)
Comment 29 JBoss JIRA Server 2013-08-28 11:32:07 EDT
Paul Leacu <pleacu@redhat.com> made a comment on jira JBTIS-149

http://download.jboss.org/jbosstools/updates/integration/kepler/integration-stack/aggregate/4.1.2/

should have the latest bpel in it now.
Comment 30 JBoss JIRA Server 2013-08-28 12:52:12 EDT
Robert (Bob) Brodt <bbrodt@redhat.com> made a comment on jira JBTIS-149

Nope, it doesn't. Still has the old timestamp from 1.0.3V20130816-0911-H221-CI. It should be 1.0.3.v20130816-0854-CI
Comment 31 Nick Boldt 2013-08-28 14:10:37 EDT
I believe the reason you're still seeing the old H221 version is that until moments ago (when I committed a fix and pushed it to download.jboss.org), the JBTIS "latest target platform" URL [1] still pointed at the 4.1.2.Final TP rather than the updated 4.1.3.Final version.

So even though the correct bits were published to the BPEL site [2], they are NOT aggregated into the JBTIS site [3] and so when JBTIS looks at its TP to resolve deps, it was finding the older stuff instead.

[1] http://download.jboss.org/jbosstools/updates/kepler/integration-stack/

[2] http://download.jboss.org/jbosstools/updates/development/kepler/integration-stack/bpel/1.2.100.Final/

[3] http://download.jboss.org/jbosstools/updates/integration/kepler/integration-stack/aggregate/4.1.2/

Please try again, thanks!
Comment 32 JBoss JIRA Server 2013-08-28 15:24:43 EDT
Paul Leacu <pleacu@redhat.com> made a comment on jira JBTIS-149

Good sleuthing Nick.  This [1] now has the 20130816-0854-CI BPEL Runtime feature.


   [1] http://download.jboss.org/jbosstools/updates/integration/kepler/integration-stack/aggregate/4.1.2/
Comment 33 JBoss JIRA Server 2013-08-28 15:40:07 EDT
Paul Leacu <pleacu@redhat.com> made a comment on jira JBTIS-149

Bob Brodt has verified the fix on the engineering side.  Closing the JBTIS JIRA - will reassign the bugzilla back to QE for final verification.
Comment 34 JBoss JIRA Server 2013-08-28 15:40:35 EDT
Paul Leacu <pleacu@redhat.com> updated the status of jira JBTIS-149 to Resolved
Comment 35 JBoss JIRA Server 2013-08-28 15:40:35 EDT
Paul Leacu <pleacu@redhat.com> made a comment on jira JBTIS-149

see previous comment - fixed in JBTIS 4.1.2
Comment 36 Jiri Sedlacek 2013-08-30 04:48:31 EDT
seems to be working now, marking as verified.
Comment 40 JBoss JIRA Server 2015-02-11 02:38:32 EST
Andrej Podhradsky <apodhrad@redhat.com> updated the status of jira JBTIS-149 to Closed

Note You need to log in before you can comment on or make changes to this bug.