Bug 996915 - Oneway service with RemoteInvoker propagates faults to client
Oneway service with RemoteInvoker propagates faults to client
Status: CLOSED WONTFIX
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Keith Babo
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 05:31 EDT by Jiri Sedlacek
Modified: 2015-08-02 19:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 14:26:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Sedlacek 2013-08-14 05:31:19 EDT
When I call oneway service with remote invoker and fault happens on server, there should be no fault propagated to the client. Now it is.
Comment 1 Keith Babo 2013-08-14 18:56:01 EDT
This is by design to allow consumers to deal with runtime faults.  It was an enhancement added in 1.0 and is definitely not a bug.  The only thing that can/should really change here is adding the ability to detect an application fault (via Exchange.sendFault()) and not return those.  Today, all faults are passed back to the consumer in case they want to know the outcome of an exchange.  That said, we can detect and restrict this behavior to only report runtime faults.

Not a beta blocker.
Comment 3 kconner 2013-09-24 14:26:33 EDT
Keith and I have discussed this and we have decided to close this as it is expected behaviour at present.

Note You need to log in before you can comment on or make changes to this bug.