Bug 996941 - Product logo not present in Administration Console
Product logo not present in Administration Console
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ER7
: EAP 6.1.1
Assigned To: Heiko Braun
Jakub Cechacek
Russell Dickenson
: Regression
Depends On:
Blocks: 998728
  Show dependency treegraph
 
Reported: 2013-08-14 06:26 EDT by Nikoleta Ziakova
Modified: 2015-02-01 18:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:25:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Admin console in EAP 6.1.1 ER5 (89.80 KB, image/png)
2013-08-14 06:26 EDT, Nikoleta Ziakova
no flags Details
Admin console in EAP 6.1.1 ER4 with prod_name image (97.92 KB, image/png)
2013-08-14 06:29 EDT, Nikoleta Ziakova
no flags Details
Header changed in ER5 since ER4 (4.34 KB, patch)
2013-08-14 09:05 EDT, Yong Yang
no flags Details | Diff
Former logo (7.35 KB, image/png)
2013-08-16 08:31 EDT, Harald Pehl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker HAL-143 Major Closed Restore former EAP logo 2014-07-03 08:24:35 EDT

  None (edit)
Description Nikoleta Ziakova 2013-08-14 06:26:40 EDT
Created attachment 786489 [details]
Admin console in EAP 6.1.1 ER5

Admin console in EAP 6.1.1 ER5 contains text "EAP" instead of logo "welcome-content/images/prod_name.png". This image is present in bits but is not referenced. See attached screenshot.
Comment 1 Nikoleta Ziakova 2013-08-14 06:29:20 EDT
Created attachment 786493 [details]
Admin console in EAP 6.1.1 ER4 with prod_name image
Comment 2 Yong Yang 2013-08-14 09:05:17 EDT
Created attachment 786532 [details]
Header changed in ER5 since ER4

According to Header.java diff between ER5 and ER4 in hal/core, I believe this is an planed change.

So if we want to get the product logo image back, maybe need to create a feature request to upstream project.
Comment 3 Carlo de Wolf 2013-08-14 09:45:27 EDT
It is a regression, not a feature.
Comment 4 Paul Gier 2013-08-14 09:51:18 EDT
Related upstream issue:
https://issues.jboss.org/browse/HAL-117
Comment 5 Catherine Robson 2013-08-15 11:00:56 EDT
Expected branding and versioning solution:

"Red Hat JBoss Enterprise Application Platform" logo should be in the header.  Note that we need a new logo image with "Red Hat" at the beginning of it.  I will attached the current one I have from brand in both svg and eps format.  I can create another format if needed, or we can get another logotype from brand if this one does not work for any reason.

There should be NO version in the header of the application.  The version number should be removed.

The footer contains the version number, and this should accurately reflect the current version of the software.
Comment 10 Harald Pehl 2013-08-16 08:28:23 EDT
There are several options to solve the issue

1. Stick with the current solution: The console header will render the text "EAP 6.1.1". This will require no new HAL console release.

2. Change the product name to a more meaningful name like "JBoss EAP". This needs a modification of the MANIFEST.MF in the module "org.jboss.as.product", slot "eap". However it's not sure if this will have any side effects. After the modification the header will show the text "JBoss EAP 6.1.1". This will require no new HAL release.

3. Go back to the old solution and display an image in the header (see attachment). This will require a new HAL release.

Some background: The reason why we replaced the image with a textual representation of the product name, is that HAL targets many different layered products. Providing a logo for every possible product, would be very difficult. 

If we choose to use the old logo (option 3). We can supply a new HAL release early next week.
Comment 11 Harald Pehl 2013-08-16 08:31:59 EDT
Created attachment 787232 [details]
Former logo
Comment 12 Catherine Robson 2013-08-16 10:02:19 EDT
I'm not understanding why we have the version number as part of this product name area.  There is another version number in the footer that does not match.  Can you please explain this more?

My preference would still be towards #3, but maybe I don't understand the 'problem' of having many product logos.  How is having a list of product logo images and sourcing in the correct one during the productization process difficult exactly?  Just trying to understand the problem more!
Comment 13 Harald Pehl 2013-08-16 11:10:26 EDT
Prepared HAL 1.5.7.Final which restores the former logo. The version is not yet released but in the nexus staging area. I will finish the release once we agree to use it for EAP 6.1.1
Comment 14 Catherine Robson 2013-08-16 11:13:08 EDT
Are we able to use the new product logo instead of the old one since it has the proper branding?  I can turn it into a png file if that is what is required.
Comment 15 Heiko Braun 2013-08-19 03:49:32 EDT
Until there is no well defined workflow who is gojng to provide these logo's and at what point, I am going to reject this request from a dev point of view (flagged appropriatly).

@Catherine Once the provisiong of product logo's (for each and every product that builds on EAP) is in place, we can revisit this requirement.
Comment 16 Jakub Cechacek 2013-08-19 09:29:56 EDT
There are no changes allowed in branding for 6.1.1 release, thus missing logo is regression against 6.1.0.GA from QE point of view. As there is going to be ER7 build for 6.1.1 anyway we would like to have this fixed - as previously discussed with Mark and Harald.
Comment 19 JBoss JIRA Server 2013-08-19 15:01:26 EDT
Harald Pehl <hpehl@redhat.com> updated the status of jira HAL-143 to Resolved
Comment 20 Paul Gier 2013-08-19 18:35:30 EDT
PR to revert to the old logo: https://github.com/jbossas/jboss-eap/pull/297
Comment 21 Nikoleta Ziakova 2013-08-22 04:34:50 EDT
Verified for EAP 6.1.1 ER7
Comment 23 JBoss JIRA Server 2014-06-30 11:00:29 EDT
Heiko Braun <ike.braun@googlemail.com> updated the status of jira HAL-143 to Closed

Note You need to log in before you can comment on or make changes to this bug.