Bug 996943 - Policy definitions are not stored in the S-RAMP repository as distinct entities
Policy definitions are not stored in the S-RAMP repository as distinct entities
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER3
: ---
Assigned To: Eric Wittmann
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 06:34 EDT by Stefan Bunciak
Modified: 2015-08-02 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SRAMP-231 Major Closed SwitchYard XML deriver missing 'requires' attribute on component services 2014-04-07 10:07:31 EDT

  None (edit)
Description Stefan Bunciak 2013-08-14 06:34:07 EDT
Description of problem:

According to PRD/ERD Requirement ID(s): SOA-GOV-7

Requirement:
 Policy definitions and enforcement handlers should be able to be stored in the repository as distinct entities. Tooling should enable the user to locate a policy and “assign” to a service.
Comments:
S-RAMP will be able to extract switchyard policies as a derived artifact.  There will be no support for storing BAM policies other than through code artifacts.

Version-Release number of selected component (if applicable):
EAP6.1 + S-RAMP + DTGov aimed for SOA 6.0.0.ER1

How reproducible:
* Always

Steps to Reproduce:
1. Deploy switchyard-quickstart-policy-* project to S-RAMP
2. Explore S-RAMP repo content in sramp-ui

Actual results:

* SwitchYard policy definitions (security,transaction) are not explicitly listed as distinct entities in S-RAMP(-ui)

Expected results:

* SwitchYard policy definitions (security,transaction) are explicitly listed as distinct entities in S-RAMP and can be associated with Services deployed in repository

Additional info:
Comment 1 Eric Wittmann 2013-08-14 08:43:42 EDT
The SwitchYard deriver (responsible for auto-deriving content from the switchyard.xml file) pulls out the policy information as simple custom properties rather than distinct derived artifacts.  The reason is that the policy in the switchyard.xml is a simple value of an attribute.  I used this information as the basis for this:

https://docs.jboss.org/author/display/SWITCHYARD/Policy

The JIRA for the development of the switchyard deriver is:

https://issues.jboss.org/browse/SRAMP-156

I believe the relevant pull request for the policy attribute is:

https://github.com/Governance/s-ramp/pull/271

Since the policy is just a value in an attribute, there didn't seem to be a point to making it a separate unique artifact (there is no additional meta-data).

If more needs to be done I'm happy to be advised what it is. :)
Comment 2 Stefan Bunciak 2013-08-20 08:50:35 EDT
This SwitchYard deriver is just exploring implementation.bean tag for the 'requires' attribute but security policies are defined in service tag[0] so security/custom policies are just ignored.

[0] https://github.com/jboss-switchyard/quickstarts/blob/master/demos/policy-security-wss-username/src/main/resources/META-INF/switchyard.xml
Comment 3 JBoss JIRA Server 2013-08-30 15:23:34 EDT
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira SRAMP-231 to Coding In Progress
Comment 4 JBoss JIRA Server 2013-09-03 13:34:40 EDT
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira SRAMP-231 to Resolved
Comment 5 JBoss JIRA Server 2013-09-03 13:35:06 EDT
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira SRAMP-231 to Closed
Comment 6 JBoss JIRA Server 2013-09-03 13:36:49 EDT
Eric Wittmann <eric.wittmann@redhat.com> made a comment on jira SRAMP-231

Note - I added new derived artifacts with type ComponentService.  This new artifact type is for the <service> children from a <component>  This is where you can find the 'requires' attribute value.
Comment 7 Stefan Bunciak 2013-09-10 07:10:57 EDT
This patch probably hasn't been included in ER2 build. I've deployed SwitchYard application with custom policy defined and an application with security policy defined and no artifacts with 'requires' attribute were found in S-RAMP repository browser (http://localhost:8080/s-ramp-ui/#artifacts).
Comment 8 Eric Wittmann 2013-09-10 07:50:32 EDT
Stefan, am I correct in assuming that you don't get any derived artifacts of type ComponentService at all?
Comment 9 Stefan Bunciak 2013-09-10 07:56:41 EDT
Your assumption is correct.

(In reply to Eric Wittmann from comment #8)
> Stefan, am I correct in assuming that you don't get any derived artifacts of
> type ComponentService at all?
Comment 10 Stefan Bunciak 2013-09-23 07:20:40 EDT
Verified in FSW 6.0.0.ER3. Artifacts of type SwitchYardComponentService contains 'requires' attribute with appropriate policy type (security,transaction,custom).

Note You need to log in before you can comment on or make changes to this bug.