Bug 996955 - tkey-gssapi-credential option in /etc/named.conf creates a memory leak
tkey-gssapi-credential option in /etc/named.conf creates a memory leak
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind (Show other bugs)
6.4
All Linux
urgent Severity high
: rc
: ---
Assigned To: Tomáš Hozza
qe-baseos-daemons
: Patch, ZStream
Depends On: 911167
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 07:01 EDT by Jan Kurik
Modified: 2013-08-27 04:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* Due to a missing gss_release_name() call, the BIND DNS server leaked memory when the "tkey-gssapi-credential" option was used in the BIND configuration. This update properly frees all memory in case the "tkey-gssapi-credential" is used, and BIND no longer leaks memory when GSSAPI credentials are used internally by the server for authentication.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 04:15:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1177 normal SHIPPED_LIVE bind bug fix update 2013-08-27 08:14:02 EDT

  None (edit)
Description Jan Kurik 2013-08-14 07:01:50 EDT
This bug has been copied from bug #911167 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 9 errata-xmlrpc 2013-08-27 04:15:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1177.html

Note You need to log in before you can comment on or make changes to this bug.