Bug 996965 - openstack-heat-common package should not contain tests
openstack-heat-common package should not contain tests
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-heat (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Peeler
Amit Ugol
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 07:31 EDT by Steven Hardy
Modified: 2014-06-05 05:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-12 21:19:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Hardy 2013-08-14 07:31:11 EDT
Description of problem:
Lots of tests are included in the openstack-heat-common package, they should be removed in the spec file.

rpm -ql openstack-heat-common | grep tests | wc -l
206


Version-Release number of selected component (if applicable):
openstack-heat-common-2013.2-0.3.b2.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install openstack-heat-common
2. rpm -ql openstack-heat-commo
3. Observe all the /usr/lib/python2.7/site-packages/heat/tests/* files

Additional info:

Probably also affects RHOS package
Comment 2 Jeff Peeler 2014-02-12 21:19:51 EST
This was fixed in 2013.2-0.6.b2, which was released some time ago. I keep forgetting to close these bugs out since "fedpkg update" isn't used for RDO.

Note You need to log in before you can comment on or make changes to this bug.