Bug 996972 - openstack-heat-cli package should be removed
openstack-heat-cli package should be removed
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-heat (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Peeler
Amit Ugol
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 07:44 EDT by Steven Hardy
Modified: 2014-06-05 05:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-12 21:24:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Hardy 2013-08-14 07:44:04 EDT
Description of problem:

Upstream we've moved all of the tools (except heat-manage) into a separate repo, with the intention that they will not be packaged downstream.

Essentially this is discourage use of these (mostly deprecated and/or developer tools), the primary interface to Heat should be python-heatclient (ie in alignment with all other openstack projects)

So we probably need to remove this package, and move heat-manage (into openstack-heat-common like nova, or into a toplevel package like glance and keystone?)

# rpm -ql openstack-heat-cli
/etc/bash_completion.d/heat-cfn
/etc/heat/boto.cfg
/usr/bin/heat-boto
/usr/bin/heat-cfn
/usr/bin/heat-manage
/usr/bin/heat-watch
/usr/share/doc/openstack-heat-cli-2013.2
/usr/share/doc/openstack-heat-cli-2013.2/LICENSE
/usr/share/doc/openstack-heat-cli-2013.2/README.rst
/usr/share/doc/openstack-heat-cli-2013.2/heat-cfn.html
/usr/share/man/man1/heat-boto.1.gz
/usr/share/man/man1/heat-cfn.1.gz
/usr/share/man/man1/heat-watch.1.gz

# rpm -qf /usr/bin/nova-manage
openstack-nova-common-2013.2-0.8.b2.fc20.noarch
# rpm -qf /usr/bin/keystone-manage
openstack-keystone-2013.2-0.4.b2.fc20.noarch
# rpm -qf /usr/bin/glance-manage
openstack-glance-2013.2-0.5.b2.fc20.noarch




Version-Release number of selected component (if applicable):
openstack-heat-cli-2013.2-0.3.b2.fc20.noarch


Additional info:

New upstream repo, not intended to be packaged, purely for developer usage:
https://github.com/openstack-dev/heat-cfnclient
Comment 1 Jeff Peeler 2014-02-12 21:24:13 EST
This was fixed in 2013.2-0.6.b2, which was released some time ago.

Note You need to log in before you can comment on or make changes to this bug.