Bug 996976 - Guided Decision Table: empty cells are ignored in the source
Guided Decision Table: empty cells are ignored in the source
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: manstis
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 07:57 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 08:26:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
manstis: needinfo+


Attachments (Terms of Use)
ignored cell, invalid rule (18.36 KB, image/png)
2013-08-14 07:57 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-08-14 07:57:08 EDT
Created attachment 786512 [details]
ignored cell, invalid rule

Description of problem:
If you don't fill a value into a cell, that fact pattern is ignored in the source of that row. This doesn't really make sense and creates problems once you try to update that fact in an action column.

As you can see in the screenshot, I have a Fact [f], field [==] condition column and a f, field action column updating the field on the fact from the condition column. I have one row with only the action column cell filled in.

The source code then shows this:
1. | //from row number: 1
2. | rule "Row 1 gdt"
3. |     dialect "mvel"
4. |     when
5. |     then
6. |         f.setField( "aaa" );
7. | end

As you can see, this creates an invalid rule.

This happens for any empty cell, not just those in condition columns. 

The only understandable occurrence of this is for the attribute columns, where e.g. salience without a value would again create an invalid rule.


Version-Release number of selected component (if applicable):
kie-wb 6.0 CR1
Comment 1 Edson Tirelli 2013-09-30 20:27:44 EDT
Not sure if I am understanding this correctly, but decision tables are supposed to not create conditions for empty cells. I am assigning to Michael for him to double check that is the case. If so, it is not a bug.
Comment 2 manstis 2013-10-16 07:14:33 EDT
The only scenario where this is potentially valid is where a field's data-type is String and the value is a space or spaces. Can you confirm this? Obviously the other scenario where there's an action to update an existing fact where the pattern is excluded remains a valid - and flawed - scenario.
Comment 3 manstis 2013-10-16 08:25:07 EDT
*** Bug 996964 has been marked as a duplicate of this bug. ***
Comment 4 Zuzana Krejčová 2013-10-24 08:26:47 EDT
You are right.

Based on comment 1 and comment 2, I'll be closing this as not a bug and reopening the other BZ (bug 996964), now marked as duplicate of this, since that is an issue.

Note You need to log in before you can comment on or make changes to this bug.