Bug 996983 - Windows NT 6.x BSOD with virtio SCSI driver since version 0.1.59
Windows NT 6.x BSOD with virtio SCSI driver since version 0.1.59
Status: CLOSED DUPLICATE of bug 987221
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
x86_64 Windows
unspecified Severity urgent
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
Regression
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 08:09 EDT by Anton Pomozov
Modified: 2013-08-21 00:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 00:58:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Small memory dump (262.50 KB, application/octet-stream)
2013-08-14 09:43 EDT, Anton Pomozov
no flags Details

  None (edit)
Description Anton Pomozov 2013-08-14 08:09:31 EDT
Description of problem:
BSOD trying search new devices in Device Manager.
BSOD trying to install SafeNet hasp drivers.

Version-Release number of selected component (if applicable):
both 0.1.59 and 0.1.65

How reproducible:
Always.

Steps to Reproduce:
1. Get Windows 2008R2 SP1.
2. Install driver 0.1.65 (61.65.104.6500) or 0.1.59 (61.64.104.5900) for "Red Hat VirtIO SCSI controller".
3. Press button "Scan for hardware changes" in the toolbar of the "Device Manager" snap-in.

Actual results:
BSOD.

Expected results:
No BSOD.

Additional info:
None.
Comment 2 Vadim Rozenfeld 2013-08-14 08:25:13 EDT
Hi Anton,

Please provide the following information:
- kvm, qemu, and seabios versions,
- qemu command line,
- BSOD bugcheck code.

Thanks,
Vadim.
Comment 3 Anton Pomozov 2013-08-14 09:40:37 EDT
Sorry, forgot it.

I use Proxmox VE 3.0 distributive: http://proxmox.com

# kvm --version
QEMU emulator version 1.4.2, Copyright (c) 2003-2008 Fabrice Bellard

# modinfo kvm_intel
filename:       /lib/modules/2.6.32-22-pve/kernel/arch/x86/kvm/kvm-intel.ko
license:        GPL
author:         Qumranet
srcversion:     F0AF9E1908B9CC01A9BB8BD
depends:        kvm
vermagic:       2.6.32-22-pve SMP mod_unload modversions
parm:           bypass_guest_pf:bool
parm:           vpid:bool
parm:           flexpriority:bool
parm:           ept:bool
parm:           unrestricted_guest:bool
parm:           eptad:bool
parm:           emulate_invalid_guest_state:bool
parm:           yield_on_hlt:bool
parm:           vmm_exclusive:bool
parm:           ple_gap:int
parm:           ple_window:int

# pveversion --verbose
...
running kernel: 2.6.32-22-pve
redhat-cluster-pve: 3.2.0-2
qemu-server: 3.0-20
pve-qemu-kvm: 1.4-13
...

SeaBIOS (version rel-1.7.2.1-0-g88cb66e-20130228_091731-rincewind.home.kraxel.org)

qemu command line:
/usr/bin/kvm -id 202 -chardev socket,id=qmp,path=/var/run/qemu-server/202.qmp,server,nowait -mon chardev=qmp,mode=control -vnc unix:/var/run/qemu-server/202.vnc,x509,password -pidfile /var/run/qemu-server/202.pid -daemonize -name devterm -smp sockets=1,cores=4 -nodefaults -boot menu=on -vga std -no-hpet -k en-us -m 4096 -vnc 0.0.0.0:202 -device piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2 -device usb-tablet,id=tablet,bus=uhci.0,port=1 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 -drive file=/var/lib/vz/template/iso/virtio-win-0.1-65.iso,if=none,id=drive-ide0,media=cdrom,aio=native -device ide-cd,bus=ide.0,unit=0,drive=drive-ide0,id=ide0,bootindex=200 -drive file=/dev/disk/by-id/scsi-3600144f022a8480000004d5392dc000a,if=none,id=drive-virtio0,aio=native,cache=none -device virtio-blk-pci,drive=drive-virtio0,id=virtio0,bus=pci.0,addr=0xa,bootindex=100 -netdev type=tap,id=net0,ifname=tap202i0,script=/var/lib/qemu-server/pve-bridge,vhost=on -device virtio-net-pci,mac=72:98:F9:EA:63:2A,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300 -netdev type=tap,id=net1,ifname=tap202i1,script=/var/lib/qemu-server/pve-bridge,vhost=on -device virtio-net-pci,mac=0A:A4:FB:7C:14:33,netdev=net1,bus=pci.0,addr=0x13,id=net1,bootindex=301 -rtc driftfix=slew,base=localtime -global kvm-pit.lost_tick_policy=discard

# cat /etc/pve/local/qemu-server/202.conf
#System disk%3A /dev/sdg
#Guest drivers%3A 0.1.65
#SCSI controller has driver version 0.1.52, because it's driver
#since version 0.1.59 has a critical bug falls OS to BSOD when
#scanning for hardware changes or installing new drivers.
args: -vnc 0.0.0.0:202
balloon: 1024
boot: cdn
bootdisk: virtio0
cores: 4
ide0: local:iso/virtio-win-0.1-65.iso,media=cdrom,size=60558K
memory: 4096
name: devterm
net0: virtio=72:98:F9:EA:63:2A,bridge=vmbr0
net1: virtio=0A:A4:FB:7C:14:33,bridge=vmbr1
onboot: 1
ostype: win7
scsihw: virtio-scsi-pci
sockets: 1
startup: order=25,up=240,down=120
virtio0: devserv:0.0.4.scsi-3600144f022a8480000004d5392dc000a,size=60G

Bugcheck:
0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

CRITICAL_OBJECT_TERMINATION (f4)
A process or thread crucial to system operation has unexpectedly exited or been
terminated.
Several processes and threads are necessary for the operation of the
system; when they are terminated (for any reason), the system can no
longer function.
Arguments:
Arg1: 0000000000000003, Process
Arg2: fffffa8001d39060, Terminating object
Arg3: fffffa8001d39340, Process image file name
Arg4: fffff800017dc350, Explanatory message (ascii)

Debugging Details:
------------------

----- ETW minidump data unavailable-----

PROCESS_OBJECT: fffffa8001d39060

IMAGE_NAME:  csrss.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  0

MODULE_NAME: csrss

FAULTING_MODULE: 0000000000000000 

PROCESS_NAME:  csrss.exe

EXCEPTION_CODE: (NTSTATUS) 0xc0000006 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The required data was not placed into memory because of an I/O error status of "0x%08lx".

BUGCHECK_STR:  0xF4_IOERR

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT_SERVER

CURRENT_IRQL:  0

STACK_TEXT:  
fffff880`02e7f0e8 fffff800`01863d22 : 00000000`000000f4 00000000`00000003 fffffa80`01d39060 fffffa80`01d39340 : nt!KeBugCheckEx
fffff880`02e7f0f0 fffff800`0181008b : ffffffff`ffffffff fffffa80`01e51060 fffffa80`01d39060 fffffa80`01d39060 : nt!PspCatchCriticalBreak+0x92
fffff880`02e7f130 fffff800`01790144 : ffffffff`ffffffff 00000000`00000001 fffffa80`01d39060 00000000`00000008 : nt! ?? ::NNGAKEGL::`string'+0x17486
fffff880`02e7f180 fffff800`014d4e93 : fffffa80`01d39060 fffff800`c0000006 fffffa80`01e51060 00000000`00950f50 : nt!NtTerminateProcess+0xf4
fffff880`02e7f200 fffff800`014d1450 : fffff800`0152081f fffff880`02e7fb78 fffff880`02e7f8d0 fffff880`02e7fc20 : nt!KiSystemServiceCopyEnd+0x13
fffff880`02e7f398 fffff800`0152081f : fffff880`02e7fb78 fffff880`02e7f8d0 fffff880`02e7fc20 00000000`00951af0 : nt!KiServiceLinkage
fffff880`02e7f3a0 fffff800`014d5282 : fffff880`02e7fb78 00000000`00013600 fffff880`02e7fc20 00000000`009515c8 : nt! ?? ::FNODOBFM::`string'+0x488e4
fffff880`02e7fa40 fffff800`014d3dfa : 00000000`00000000 000007fe`fe11d8c0 00000000`00000001 00000000`00013600 : nt!KiExceptionDispatch+0xc2
fffff880`02e7fc20 00000000`77ca9c12 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x23a
00000000`00951510 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x77ca9c12


STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

FAILURE_BUCKET_ID:  X64_0xF4_IOERR_IMAGE_csrss.exe

BUCKET_ID:  X64_0xF4_IOERR_IMAGE_csrss.exe

Followup: MachineOwner
---------
Comment 4 Anton Pomozov 2013-08-14 09:43:13 EDT
Created attachment 786539 [details]
Small memory dump

Windows 2008R2 SP1
Comment 5 Mike Cao 2013-08-20 08:31:23 EDT
jguo ,pls try to reproduce it
Comment 6 guo jiang 2013-08-20 23:44:35 EDT
(In reply to Mike Cao from comment #5)
> jguo ,pls try to reproduce it

This bug maybe duplicate 987221.
Comment 7 Vadim Rozenfeld 2013-08-21 00:08:59 EDT
(In reply to guo jiang from comment #6)
> (In reply to Mike Cao from comment #5)
> > jguo ,pls try to reproduce it
> 
> This bug maybe duplicate 987221.

yes it is. 
as well 998405.

Best regards,
Vadim.
Comment 8 Mike Cao 2013-08-21 00:58:37 EDT

*** This bug has been marked as a duplicate of bug 987221 ***

Note You need to log in before you can comment on or make changes to this bug.