Bug 996993 - [RFE] Search for or list matching providedProducts
[RFE] Search for or list matching providedProducts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carter Kozak
John Sefler
: FutureFeature
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-08-14 08:48 EDT by Matthew Mosesohn
Modified: 2016-04-26 10:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
Updates of subscription-manager list Among the list of available subscription, the output of the subscription-manager list --available command now contains a new field, Provides. This field shows the names of the products that the system is eligible for. In addition, a new field, Suggested, has been added to facilitate compliance and provide parity with the graphical user interface (GUI). (BZ#996993, BZ#1008557)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:27:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Mosesohn 2013-08-14 08:48:50 EDT
Description of problem:
Adding Red Hat OpenStack is quite difficult for certain corner cases, such as Red Hat Employee Subscriptions. It should be easy to tell subscription-manager to list the required product ID that my system is eligible for and contains a particular product inside. In this case, I want 'Red Hat OpenStack', but I may have some cryptic title in the productName (or even dozens of entries that don't!) which may or may not contain the desirable ambrosia within.

Version-Release number of selected component (if applicable):
subscription-manager-1.1.23.1-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. subscription-manager list --available
2.
3.

Actual results:


Expected results:
A list of products and subproducts that I can parse or search explicitly.

Additional info:
This capability is already in python-rhsm and is in the JSON returned to the client, but it's just not used by subscription-manager.
Comment 1 Perry Myers 2013-08-14 09:02:27 EDT
Matt, can you give an example (mock up) of what the subscription-manager command would look like and what the desired output would be?
Comment 3 Matthew Mosesohn 2013-08-14 09:16:57 EDT
Proposed improvement: list option --verbose
# subscription-manager list --available --verbose
Subscription Name:    	Red Hat OpenStack Business Partner Self-Supported NFR
Provided Products:      Red Hat Enterprise Linux Server
                        Red Hat Enterprise Linux Load Balancer (for RHEL Server)
                        Red Hat Enterprise Linux High Availability (for RHEL Server)
                        Red Hat OpenStack
SKU:                  	SER0418
Pool Id:              	99999999999999999999999999999999
Quantity:             	32
Service Level:        	Self-Support
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	05/29/2014
System Type:          	Physical


Proposed new feature: search 
# subscription-manager search OpenStack --verbose
Subscription Name:    	Red Hat OpenStack Business Partner Self-Supported NFR
Provided Products:      Red Hat Enterprise Linux Server
                        Red Hat Enterprise Linux Load Balancer (for RHEL Server)
                        Red Hat Enterprise Linux High Availability (for RHEL Server)
                        Red Hat OpenStack
SKU:                  	SER0418
Pool Id:              	99999999999999999999999999999999
Quantity:             	32
Service Level:        	Self-Support
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	05/29/2014
System Type:          	Physical

# subscription-manager search OpenStack
Subscription Name:    	Red Hat OpenStack Business Partner Self-Supported NFR
SKU:                  	SER0418
Pool Id:              	99999999999999999999999999999999
Quantity:             	32
Service Level:        	Self-Support
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	05/29/2014
System Type:          	Physical
Comment 6 Carter Kozak 2013-09-27 10:14:49 EDT
This feature should be included in rhel 6.5
Additionally, I am working on a --match-installed option for list --available in rhel7

commit b8738a74c1109975e387fc51105c8ff58eaa8f01
Author: ckozak <ckozak@redhat.com>
Date:   Thu Sep 26 15:45:36 2013 -0400

    996993: add provided to list available
Comment 10 John Sefler 2013-10-03 14:38:53 EDT
Verifying Version...
[root@jsefler-6 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.28-1
subscription-manager: 1.9.8-1.el6
python-rhsm: 1.9.6-1.el6


[root@jsefler-6 ~]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name: Multi-Attribute (non-stackable) (24 cores, 6 sockets, 8GB RAM)
Provides:          Multi-Attribute Limited Product
SKU:               non-stacked-multiattr
Pool ID:           8a9087404175311a01417531d4e304b3
Available:         5
Suggested:         1
Service Level:     Super
Service Type:      Level 3
Multi-Entitlement: No
Ends:              09/30/2014
System Type:       Physical

Subscription Name: Awesome OS Server Bundled (2 Sockets, Standard Support)
Provides:          Management Bits
                   Load Balancing Bits
                   Shared Storage Bits
                   Clustering Bits
                   Awesome OS Server Bits
                   Awesome OS Server Bundled
                   Large File Support Bits
SKU:               awesomeos-server-2-socket-std
Pool ID:           8a9087404175311a01417531ee531212
Available:         5
Suggested:         1
Service Level:     Standard
Service Type:      L1-L3
Multi-Entitlement: No
Ends:              09/30/2014
System Type:       Physical

Subscription Name: Awesome OS Server Basic (data center)
Provides:          
SKU:               awesomeos-server-basic-dc
Pool ID:           8a9087404175311a01417531f250152f
Available:         5
Suggested:         1
Service Level:     None
Service Type:      Self-Support
Multi-Entitlement: No
Ends:              09/30/2014
System Type:       Physical


VERIFIED: Notice that among the list of available subscriptions, a new field caled "Provides" now shows you the names of the engineering product(s) that the subscription will cover once it is attached to the system.

The notion of a search and verbose function are being considered as a future feature.  For RHEL65, the new "Provides" field will always be printed among the subscription-manager list of --available subscriptions.
Comment 11 errata-xmlrpc 2013-11-21 16:27:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.