Bug 997009 - requiredSecret attribute on the AJP connector
requiredSecret attribute on the AJP connector
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium
: ER1
: EAP 6.2.0
Assigned To: Tom Fonteyne
Radim Hatlapatka
:
: 997007 (view as bug list)
Depends On:
Blocks: 1005130
  Show dependency treegraph
 
Reported: 2013-08-14 09:23 EDT by Tom Fonteyne
Modified: 2017-10-09 20:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When using a load balancing Apache server in front of JBoss EAP 5.x, you can set the "requiredSecret" attribute of the AJP connector. This is used to only allow requests from load-balancer workers with the same secret keyword, to be accepted. In JBoss EAP 6.0.x and 6.1.x it was not possible to configure this value. This issue has now resolved and you can now set a system property to your required value for the "requiredSecret" attribute: ---- org.apache.coyote.ajp.DEFAULT_REQUIRED_SECRET=yoursecretvalue ----
Story Points: ---
Clone Of:
: 1005130 (view as bug list)
Environment:
Last Closed: 2013-12-15 11:19:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1589 Minor Resolved requiredSecret attribute on the AJP connector 2016-04-12 14:46 EDT

  None (edit)
Description Tom Fonteyne 2013-08-14 09:23:19 EDT
In JBoss 5 I could set the requiredSecret attribute of the AJP connector. This is no longer possible in JBoss EAP 6.0.0/6.0.1/6.1.0/6.1.1

This is a backport of https://issues.jboss.org/browse/WFLY-1589
to get the functionality in the EAP 6.2.0 release
Comment 1 Tom Fonteyne 2013-08-14 11:14:48 EDT
$ svn ci -m "[bz-997009] allow configuration of requiredSecret attribute on the AJP connector with a system property"
Sending        src/main/java/org/apache/coyote/ajp/AjpAprProtocol.java
Sending        src/main/java/org/apache/coyote/ajp/AjpProtocol.java
Sending        src/main/java/org/apache/coyote/ajp/Constants.java
Transmitting file data ...
Committed revision 2246.
Comment 3 Radim Hatlapatka 2013-09-12 09:08:34 EDT
Verified with EAP 6.2.0.ER1
Comment 5 Radim Hatlapatka 2014-08-01 10:12:14 EDT
*** Bug 997007 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.