Bug 997012 - Reassignment of task does not happen after fail over
Reassignment of task does not happen after fail over
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER3
: 6.0.0
Assigned To: Maciej Swiderski
Radovan Synek
:
Depends On: 1011008
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 09:26 EDT by Radovan Synek
Modified: 2014-08-06 16:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
process definition (6.96 KB, application/xml)
2013-08-14 09:26 EDT, Radovan Synek
no flags Details
node one server log (606.57 KB, text/x-log)
2013-08-14 09:28 EDT, Radovan Synek
no flags Details
node two server log (374.81 KB, text/x-log)
2013-08-14 09:28 EDT, Radovan Synek
no flags Details

  None (edit)
Description Radovan Synek 2013-08-14 09:26:01 EDT
Created attachment 786534 [details]
process definition

Description of problem:
See the attached process definition. It's a simple process containing a human task with notification & reassignment configured. This process has been deployed to jBPM cluster (two EAP 6.1 nodes) and started on the first node. The was waiting for the task to be started when node 1 was shut down. After waiting for 1 minute to let the cluster move the computation to the second node and the reassignment to take effect, the potential owner of the task hasn't changed. I would expect reassignment from "user" to "admin", but the potential owner was still "user".
I tried this scenario with standalone server (no cluster, no fail over) and it worked.

I am attaching server logs from both nodes, there are several stacktraces with quartz, so I guess they can be relevant to this issue.

The cluster has been started with clean DB (mysql 55) and erased .niogit on both nodes.

Version-Release number of selected component (if applicable):
community 6.0.0.CR1
Comment 1 Radovan Synek 2013-08-14 09:28:18 EDT
Created attachment 786535 [details]
node one server log
Comment 2 Radovan Synek 2013-08-14 09:28:47 EDT
Created attachment 786536 [details]
node two server log
Comment 3 Maciej Swiderski 2013-08-22 08:16:34 EDT
problem was caused by the deadline job in cluster was not properly serialized and thus was not possible to be executed on another server than it was created. Mechanism for deadlines has been improved so it is properly serialized when storing the job details in db.

Fix requires commits from kie-commons and jbpm

https://github.com/droolsjbpm/kie-commons/commit/e7eccc4d35dad0078805bc1e5687fb8b679dbc3f
https://github.com/droolsjbpm/jbpm/commit/d844820c3e78072690c1b92826ce1f0c6cf43a2f
Comment 4 Lukáš Petrovický 2013-08-22 08:20:53 EDT
Moving to an arbitrary future milestone, as this hasn't been fixed in ER1.
Comment 8 Radovan Synek 2013-10-17 11:15:41 EDT
Verified on BPMS-6.0.0.ER4

Note You need to log in before you can comment on or make changes to this bug.