Bug 997014 - Please do not echo the last letter in the password dialog
Please do not echo the last letter in the password dialog
Status: CLOSED DUPLICATE of bug 994237
Product: Fedora
Classification: Fedora
Component: lightdm-gtk (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 09:27 EDT by Jaroslav Škarvada
Modified: 2013-08-14 09:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 09:52:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2013-08-14 09:27:27 EDT
Description of problem:
I know this is "cool and in" feature copied from tablets, but on desktops this is useless and very unsecure. When typed in quickly (as passwords are usually typed), I can easily read the whole password and other folks near my LCD screen can do the same. This renders the user passwords useless. Maybe Fedora is used on tablets by some folks but it is minority in comparison with desktop / laptop users. Please provide an option for disabling this "feature" and ship it disabled in Fedora by default.

Version-Release number of selected component (if applicable):
lightdm-1.7.9-2.fc20

How reproducible:
Always

Steps to Reproduce:
1. Type password in login dialog
2.
3.

Actual results:
Last letters are echoed, if typed in quickly the whole password can be easily read.

Expected results:
No letters are echoed.

Additional info:
Comment 1 Rex Dieter 2013-08-14 09:31:55 EDT
I think this is either a gtk feature or one of the lightdm-gtk greeter.

(For example, using these same lightdm builds on f19, I don't see what you describe).
Comment 2 Jaroslav Škarvada 2013-08-14 09:40:20 EDT
(In reply to Rex Dieter from comment #1)
> I think this is either a gtk feature or one of the lightdm-gtk greeter.
> 
Probably, sorry for wrong component.

$ pgrep -l lightdm-gtk
lightdm 2268 2266 4 15:36 ?    00:00:00 /usr/sbin/lightdm-gtk-greeter

This shows in Xfce desktop default installation.
Comment 3 Rex Dieter 2013-08-14 09:52:12 EDT
ok, confirmed a gtk3 issue, see bug #994237

*** This bug has been marked as a duplicate of bug 994237 ***

Note You need to log in before you can comment on or make changes to this bug.