Bug 997027 - spacewalk-report host-guests failed - external oracle
spacewalk-report host-guests failed - external oracle
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Duryee
Pavel Studeník
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-08-14 10:01 EDT by Pavel Studeník
Modified: 2013-10-01 17:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-reports-2.0.1-5-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:48:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Studeník 2013-08-14 10:01:18 EDT
Description of problem:
I upgraded satellite from 5.5 to 5.6 (external oracle with customer's data). 
Spacewalk-report with parameter host-guests is new feature in Satellite 5.6 and it doesn't work.

Version-Release number of selected component (if applicable):
spacewalk-reports-2.0.1-4.el6sat.noarch
spacewalk-schema-2.0.2-8.el6sat.noarch

How reproducible:
always with backup customer database

Steps to Reproduce:
1. register some guests to satellite
2. run spacewalk-report host-guests

Actual results:
>>> spacewalk-report host-guests
SQL error occurred, traceback follows...
Traceback (most recent call last):
  File "/usr/bin/spacewalk-report", line 198, in <module>
    h.execute(**dict(report.params.items()   the_dict_where.items()))
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/sql_base.py", line 163, in execute
    return apply(self._execute_wrapper, (self._execute, )   p, kw)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/driver_cx_Oracle.py", line 108, in _execute_wrapper
    retval = apply(function, p, kw)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/sql_base.py", line 217, in _execute
    return self._execute_(args, kwargs)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/driver_cx_Oracle.py", line 161, in _execute_
    self._real_cursor.execute(*(None, ), **params)
spacewalk.server.rhnSQL.sql_base.SQLStatementPrepareError: ('ORA-00911: invalid character\n', 911, 'select host_system_id as server_id, virtual_system_id as guests from rhnvirtualinstance where host_system_id is not null and virtual_system_id is not null order by server_id;')

Expected results:
spacewalk-report works
Comment 1 Stephen Herr 2013-08-14 14:39:33 EDT
Committed to Spacewalk master:
7f90ecca40b7d190434a92acc0d08e785506cf4f
Comment 5 Clifford Perry 2013-10-01 17:48:58 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.