Bug 997041 - Cloud guest images needs to have "NOZEROCONF=yes" in /etc/sysconfig/network
Cloud guest images needs to have "NOZEROCONF=yes" in /etc/sysconfig/network
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: guest-images (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Mike Burns
: ZStream
Depends On: 983611
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 10:35 EDT by Chris Pelland
Modified: 2013-10-30 11:50 EDT (History)
11 users (show)

See Also:
Fixed In Version: rhel-guest-image-6.4-2
Doc Type: Bug Fix
Doc Text:
* Metadata access is handled by the network node, and the cloud-init service uses the metadata at startup time. Previously, the cloud-init service did not have "NOZEROCONF=yes" configured. Consequently, access to the subnet 169.254.0.0/16 range was not routed to the network node, so the cloud-init service failed to work. This update adds "NOZEROCONF=yes" to cloud images in the /etc/sysconfig/network file. Users should avoid turning on the zeroconf route in these images. To disable the zeroconf route at system boot time, edit the /etc/sysconfig/network file as root and add "NOZEROCONF=yes" to a new line at the end of the file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 11:50:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2013-08-14 10:35:38 EDT
This bug has been copied from bug #983611 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 5 Wei Shi 2013-10-08 05:39:04 EDT
Verified:

rhel-server-x86_64-kvm-6.4_20130130.0-9

# cat /etc/sysconfig/network
NETWORKING=yes
NETWORKING_IPV6=no
HOSTNAME=virtlab-66-85-160.englab.nay.redhat.com
NOZEROCONF=yes
Comment 13 Gilles Dubreuil 2013-10-30 00:19:44 EDT
This one to go back to VERIFIED status as I interfered with its state in the first place.

Put I can't (and probably shouldn't) do that.
Comment 15 errata-xmlrpc 2013-10-30 11:50:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1481.html

Note You need to log in before you can comment on or make changes to this bug.