Bug 997084 - Fix policy classes for --tmp-dir
Fix policy classes for --tmp-dir
Status: CLOSED DUPLICATE of bug 997083
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryn M. Reeves
BaseOS QE - Apps
: EasyFix, Patch, Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 11:59 EDT by Bryn M. Reeves
Modified: 2013-10-01 09:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 09:56:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2013-08-14 11:59:41 EDT
Description of problem:
Policy classes need to return the user-supplied temporary
directory if they decide not to override it.


Version-Release number of selected component (if applicable):
sos-3.0-2.el7

How reproducible:
100%

Steps to Reproduce:
1. sosreport --tmp-dir=$some_path

Actual results:
--tmp-dir is not respected

Expected results:
--tmp-dir is used unless a policy module explicitly overrides it.


Additional info:
Upstream commit bc77b20
Comment 1 Lukas Zachar 2013-10-01 09:56:24 EDT

*** This bug has been marked as a duplicate of bug 997083 ***

Note You need to log in before you can comment on or make changes to this bug.