Bug 997113 - Headpin Nightly : Cli command displaying info for activation key failed
Headpin Nightly : Cli command displaying info for activation key failed
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On: 989931
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 13:25 EDT by Bryan Kearney
Modified: 2013-10-08 13:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 989931
Environment:
Last Closed: 2013-10-08 13:11:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2013-08-14 13:25:09 EDT
+++ This bug was initially created as a clone of Bug #989931 +++

Description of problem:
Cli command displaying info for activation key failed

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-certs-tools-1.4.2-1.el6.noarch
katello-glue-candlepin-1.4.2-1.git.970.aad75f0.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.2-1.git.137.fea0d84.el6.noarch
katello-cli-common-1.4.2-1.git.137.fea0d84.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.970.aad75f0.el6.noarch
katello-headpin-1.4.2-1.git.970.aad75f0.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
katello-common-1.4.2-1.git.970.aad75f0.el6.noarch
katello-headpin-all-1.4.2-1.git.970.aad75f0.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-repos-1.4.2-1.el6.noarch


How reproducible:
# yum install -y katello-headpin-all
# katello-configure --deployment=headpin --user-pass=****

Steps to Reproduce:
1.# headpin -u admin -p ***** activation_key create --name act_key --org ACME_Corporation
Successfully created activation key [ act_key ]

2.# headpin -u admin -p **** activation_key info --name act_key --org ACME_Corporation
Invalid resource type 'content_views'. Resource Types can be one of 'organizations, environments, activation_keys, system_groups, providers, users, roles, all'

3.

Actual results:
The cli info command failed

Expected results:
Should display information for activation key

Additional info:

--- Additional comment from Tom McKay on 2013-08-06 14:10:35 EDT ---

Branch: refs/heads/master
  Home:   https://github.com/Katello/katello-cli
  Commit: 9e2c3132dc7c1f4775564c0d6426c2a9dc195577
      https://github.com/Katello/katello-cli/commit/9e2c3132dc7c1f4775564c0d6426c2a9dc195577
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-08-06 (Tue, 06 Aug 2013)
Comment 1 RHEL Product and Program Management 2013-09-17 00:18:33 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Tom McKay 2013-10-08 13:11:11 EDT
Not applicable to katello; headpin only.

Note You need to log in before you can comment on or make changes to this bug.