This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 997188 - lvm2app: lvm_list_pvs_free segmentation fault when system has no physical volumes
lvm2app: lvm_list_pvs_free segmentation fault when system has no physical vol...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tony Asleson
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 17:24 EDT by Tony Asleson
Modified: 2013-11-21 18:27 EST (History)
10 users (show)

See Also:
Fixed In Version: lvm2-2.02.100-3.el6
Doc Type: Bug Fix
Doc Text:
When lvm_list_pvs_free lvm2app library function was called on a system with no physical volumes, a segmentation fault occured because lvm2app code tried to free an internal structure that had already been freed before. This has been fixed and the segmentation fault does not occur anymore when calling lvm_list_pvs_free function.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:27:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unit test which shows segmentation fault. (972 bytes, text/x-csrc)
2013-08-14 17:24 EDT, Tony Asleson
no flags Details

  None (edit)
Description Tony Asleson 2013-08-14 17:24:29 EDT
Created attachment 786709 [details]
Unit test which shows segmentation fault.

Description of problem:

If the system does not have any physcial volumes the call to lvm_list_pvs_free will cause a segmentation fault after a successful call to lvm_list_pvs.

How reproducible:
Every time

Steps to Reproduce:
1. Select a system that has no PVs
2. Compile and run the attached C program

Actual results:
Program crashes with segmentation fault.

Expected results:
No segmentation fault, program exit code == 0

Additional info:

Fixed in upstream:
https://lists.fedorahosted.org/pipermail/lvm2-commits/2013-August/001105.html
Comment 4 errata-xmlrpc 2013-11-21 18:27:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1704.html

Note You need to log in before you can comment on or make changes to this bug.