This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 997197 - Some AppErrors messages are grammatically incorrect (singular vs plural)
Some AppErrors messages are grammatically incorrect (singular vs plural)
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.3
Unspecified Unspecified
medium Severity low
: ---
: 3.6.0
Assigned To: Martin Mucha
Meni Yakove
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 18:24 EDT by Yuko Katabami
Modified: 2016-02-10 14:36 EST (History)
10 users (show)

See Also:
Fixed In Version: ovirt-engine-3.6.0-0.0.master.20150412172306.git55ba764
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 06:36:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 25736 master MERGED core,userportal,webadmin: added singular variant for messages. Never
oVirt gerrit 25737 master ABANDONED core,userportal,webadmin: added singular variant for messages. Never

  None (edit)
Description Yuko Katabami 2013-08-14 18:24:57 EDT
Description of problem:
The following strings in AppErrors are grammatically incorrect when the entity is singular. They only work when plural entities.


Version-Release number of selected component (if applicable): 3.3


How reproducible: Always


Steps to Reproduce: N/A
1.
2.
3.

Actual results:

1) Cannot ${action} ${type}. Several ${entities}
(${ENTITIES_USING_VNIC_PROFILE_COUNTER}) are using this VM network
interface profile:${ENTITIES_USING_VNIC_PROFILE}
- Please remove it from all ${entities} that are using it and try
again.

2) Cannot ${action} ${type}. Several ${entities} (${ENTITIES_USING_NETWORK_COUNTER}) are using this logical network:¶
${ENTITIES_USING_NETWORK}¶
 - Please remove it from all ${entities} that are using it and try again.

3) Cannot ${action} ${type}. Several external networks (${NETWORK_NAMES_COUNTER}) are being used by virtual machines and/or templates:¶
${NETWORK_NAMES}¶
 - Please resolve the external networks usage first and try again.


Expected results:
Those three messages need to be grammatically correct whether the entity is singular or plural.



Additional info:

The example of problem when the entity is singular is: 

Error while executing action: Cannot remove VM network interface profile.
Several virtual machines (1) are using this VM network interface profile:
vm1
- Please remove it from all virtual machines that are using it and try again.

1) It has the word "several" and "all" preceding the entity. Those adjectives do not work with a singular noun in all languages, and it grammatically wrong in English as well.
2) ${entities} is shown always plural even it is singular "Virtual Machines (1)" - this is not correct.
3) Verb "are" should only be used when the  nominative is plural
Comment 1 Yuko Katabami 2013-08-14 18:32:49 EDT
It would be the best if you can separate each one into two messages.

I thought of the following options, but one problem still remains which is "${entities}" always shown as plural, even when it is single.
If this point can be resolved, it may not be separated into two.



1) Cannot ${action} ${type}.This VM network interface profile ${ENTITIES_USING_VNIC_PROFILE} is currently used by the following ${entities} (${ENTITIES_USING_VNIC_PROFILE_COUNTER}):
${ENTITIES_USING_VNIC_PROFILE}
Please detach ${entities} using this profile and try again.

2) Cannot ${action} ${type}. Several
 are using 
This logical network is currently used by ${entities} (${ENTITIES_USING_NETWORK_COUNTER}): 
${ENTITIES_USING_NETWORK}¶
- Please detach ${entities} using this profile and try again.

3) Cannot ${action} ${type}. Virtual machines and/or templates are currently using external network(s) (${NETWORK_NAMES_COUNTER}):¶
${NETWORK_NAMES} 
- Please detach Virtual machines and/or templates first and try again.
Comment 2 Yuko Katabami 2013-08-14 20:38:55 EDT
(In reply to Yuko Katabami from comment #1)


> 2) Cannot ${action} ${type}. Several
>  are using 
> This logical network is currently used by ${entities}
> (${ENTITIES_USING_NETWORK_COUNTER}): 
> ${ENTITIES_USING_NETWORK}¶
> - Please detach ${entities} using this profile and try again.

Sorry, in the above, "Several are using" is meant to be removed.

It should be:

2) Cannot ${action} ${type}. This logical network is currently used by ${entities} (${ENTITIES_USING_NETWORK_COUNTER}): 
${ENTITIES_USING_NETWORK}¶
- Please detach ${entities} using this profile and try again.
Comment 3 Sandro Bonazzola 2013-11-28 10:34:07 EST
Re-targeting to 3.3.3 since the bug is not resolved in 3.3.2 beta and is not blocking 3.3.2 release tracker (bug #1027349)
Comment 4 Sandro Bonazzola 2014-03-04 06:02:18 EST
this is an automated message.
Moving remaining open bugs targeting 3.3.4 to 3.4.1.
If relevant for 3.3-stable, please reset target version accordingly.
Comment 5 Michael Burman 2015-04-29 02:52:05 EDT
Verified on - 3.6.0-0.0.master.20150412172306.git55ba764.el6

1) - Try to remove vNIC profile that is in use by 1 VM

RHEV-M
Error while executing action: Cannot remove VM network interface profile. This VM network interface profile is used by virtual machine: 6.6.
- Please remove it from this virtual machine and try again.

engine.log
2015-04-29 09:03:27,445 WARN  [org.ovirt.engine.core.bll.network.vm.RemoveVnicProfileCommand] (ajp--127.0.0.1-8702-13) [1c942a4c] CanDoAction of action 'RemoveVnicProfile' failed for user admin@internal. Reasons: VAR__TYPE__VNIC_PROFILE,VAR__ACTION__REMOVE,ACTION_TYPE_FAILED_VNIC_PROFILE_IN_ONE_USE,$ENTITIES_USING_VNIC_PROFILE        6.6,$ENTITIES_USING_VNIC_PROFILE_COUNTER 1,VAR__ENTITIES__VM

- Try to remove vNIC profile that is in use by 2 VMs

RHEV-M
Error while executing action: Cannot remove VM network interface profile. This VM network interface profile is used by virtual machines (2): micbu,
on_Qa_customMtu
- Please detach virtual machines using this profile and try again.

engine.log
2015-04-29 08:59:27,394 WARN  [org.ovirt.engine.core.bll.network.vm.RemoveVnicProfileCommand] (ajp--127.0.0.1-8702-9) [351849db] CanDoAction of action 'RemoveVnicProfile' failed for user admin@internal. Reasons: VAR__TYPE__VNIC_PROFILE,VAR__ACTION__REMOVE,ACTION_TYPE_FAILED_VNIC_PROFILE_IN_MANY_USES,$ENTITIES_USING_VNIC_PROFILE       micbu,
        on_Qa_customMtu,$ENTITIES_USING_VNIC_PROFILE_COUNTER 2,VAR__ENTITIES__VMS

- Try to remove vNIC profile that is in use by 3 VMs

RHEV-M
Error while executing action: Cannot remove VM network interface profile. This VM network interface profile is used by virtual machines (3): micbu,
on_Qa_customMtu,
6.6
- Please detach virtual machines using this profile and try again.

engine.log
2015-04-29 09:01:15,367 WARN  [org.ovirt.engine.core.bll.network.vm.RemoveVnicProfileCommand] (ajp--127.0.0.1-8702-10) [6753ee53] CanDoAction of action 'RemoveVnicProfile' failed for user admin@internal. Reasons: VAR__TYPE__VNIC_PROFILE,VAR__ACTION__REMOVE,ACTION_TYPE_FAILED_VNIC_PROFILE_IN_MANY_USES,$ENTITIES_USING_VNIC_PROFILE      micbu,
        on_Qa_customMtu,
        6.6,$ENTITIES_USING_VNIC_PROFILE_COUNTER 3,VAR__ENTITIES__VMS


2) - Try to remove network that is in use by 1 VM

RHEV-M
Error while executing action: Cannot remove Network. This logical network is used by virtual machine: 6.6
- Please remove it from this virtual machine and try again.

engine.log
2015-04-29 09:04:56,538 WARN  [org.ovirt.engine.core.bll.network.dc.RemoveNetworkCommand] (ajp--127.0.0.1-8702-7) [37454345] CanDoAction of action 'RemoveNetwork' failed for user admin@internal. Reasons: VAR__TYPE__NETWORK,VAR__ACTION__REMOVE,ACTION_TYPE_FAILED_NETWORK_IN_ONE_USE,$ENTITIES_USING_NETWORK        6.6,$ENTITIES_USING_NETWORK_COUNTER 1,VAR__ENTITIES__VM


- Try to remove network that is in use by 2 VMs

RHEV-M
Error while executing action: Cannot remove Network. This logical network is used by virtual machines: (2): micbu,
6.6
- Please detach virtual machines using this logical network and try again.

engine.log
2015-04-29 09:06:44,758 WARN  [org.ovirt.engine.core.bll.network.dc.RemoveNetworkCommand] (ajp--127.0.0.1-8702-14) [32bc09b3] CanDoAction of action 'RemoveNetwork' failed for user admin@internal. Reasons: VAR__TYPE__NETWORK,VAR__ACTION__REMOVE,ACTION_TYPE_FAILED_NETWORK_IN_MANY_USES,$ENTITIES_USING_NETWORK     micbu,
        6.6,$ENTITIES_USING_NETWORK_COUNTER 2,VAR__ENTITIES__VMS

- Try to remove network that is in use by 3 VMs

RHEV-M
Error while executing action: Cannot remove Network. This logical network is used by virtual machines: (3): micbu,
on_Qa_customMtu,
6.6
- Please detach virtual machines using this logical network and try again.

engine.log
2015-04-29 09:08:30,845 WARN  [org.ovirt.engine.core.bll.network.dc.RemoveNetworkCommand] (ajp--127.0.0.1-8702-2) [589166b0] CanDoAction of action 'RemoveNetwork' failed for user admin@internal. Reasons: VAR__TYPE__NETWORK,VAR__ACTION__REMOVE,ACTION_TYPE_FAILED_NETWORK_IN_MANY_USES,$ENTITIES_USING_NETWORK      micbu,
        on_Qa_customMtu,
        6.6,$ENTITIES_USING_NETWORK_COUNTER 3,VAR__ENTITIES__VMS


3) - Try to remove external provider that have 1 network in use

RHEV-M
Error while executing action: Cannot remove provider. External networks is used by virtual machines and/or templates:
michaelBurman
- Please resolve the external networks usage first and try again.

engine.log 
2015-04-29 09:27:01,567 WARN  [org.ovirt.engine.core.bll.provider.RemoveProviderCommand] (ajp--127.0.0.1-8702-9) [2317bcd0] CanDoAction of action 'RemoveProvider' failed for user admin@internal. Reasons: VAR__ACTION__REMOVE,VAR__TYPE__PROVIDER,ACTION_TYPE_FAILED_PROVIDER_NETWORKS_USED_ONCE,$NETWORK_NAMES       michaelBurman,$NETWORK_NAMES_COUNTER 1

- Try to remove external provider that have 2 networks in use

RHEV-M
Error while executing action: Cannot remove provider. Several external networks (2) are being used by virtual machines and/or templates:
buri5,
michaelBurman
- Please resolve the external networks usage first and try again.

engine.log
2015-04-29 09:25:15,018 WARN  [org.ovirt.engine.core.bll.provider.RemoveProviderCommand] (ajp--127.0.0.1-8702-13) [51bc7c38] CanDoAction of action 'RemoveProvider' failed for user admin@internal. Reasons: VAR__ACTION__REMOVE,VAR__TYPE__PROVIDER,ACTION_TYPE_FAILED_PROVIDER_NETWORKS_USED_MULTIPLE_TIMES,$NETWORK_NAMES    buri5,
        michaelBurman,$NETWORK_NAMES_COUNTER 2


- Try to remove external provider that have 3 networks in use

RHEV-M
Error while executing action: Cannot remove provider. Several external networks (3) are being used by virtual machines and/or templates:
buri5,
michaelBurman,
michaelBuuu
- Please resolve the external networks usage first and try again.

engine.log
2015-04-29 09:37:34,327 WARN  [org.ovirt.engine.core.bll.provider.RemoveProviderCommand] (ajp--127.0.0.1-8702-11) [365bc914] CanDoAction of action 'RemoveProvider' failed for user admin@internal. Reasons: VAR__ACTION__REMOVE,VAR__TYPE__PROVIDER,ACTION_TYPE_FAILED_PROVIDER_NETWORKS_USED_MULTIPLE_TIMES,$NETWORK_NAMES    buri5,
        michaelBurman,
        michaelBuuu,$NETWORK_NAMES_COUNTER 3
Comment 6 Sandro Bonazzola 2015-11-04 06:36:26 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.