Bug 997198 - usb camera will not connect
usb camera will not connect
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 18:26 EDT by Craig Goodyear
Modified: 2014-01-04 11:24 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-04 11:19:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Goodyear 2013-08-14 18:26:35 EDT
Description of problem:
Unable to access Nikon DSC E3100 camera with USB connection with current kernel
(3.10.5-201.fc19.x86_64).  Using kernel 3.9.9-302.fc19.x86_64, the camera will 
connect.


Output from /var/log/message with kernel 3.10.5-201.fc19.x86_64:

Aug 14 16:47:31 antec kernel: [382974.722605] usb 1-1.5: new full-speed USB device number 3 using ehci-pci
Aug 14 16:47:36 antec kernel: [382979.808654] usb 1-1.5: New USB device found, idVendor=04b0, idProduct=0114
Aug 14 16:47:36 antec kernel: [382979.808658] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Aug 14 16:47:36 antec kernel: [382979.808660] usb 1-1.5: Product: NIKON DSC E3100
Aug 14 16:47:36 antec kernel: [382979.809402] usb 1-1.5: can't set config #1, error -32
Aug 14 16:47:37 antec mtp-probe: checking bus 1, device 3: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5"
Aug 14 16:47:37 antec mtp-probe: bus: 1, device: 3 was not an MTP device


Output from /var/log/message with kernel 3.9.9-302.fc19.x86_64:

Aug 14 16:56:57 antec kernel: [  176.674791] usb 1-1.5: new full-speed USB device number 3 using ehci-pci
Aug 14 16:57:02 antec kernel: [  181.756599] usb 1-1.5: unable to read config index 0 descriptor/all
Aug 14 16:57:02 antec kernel: [  181.756603] usb 1-1.5: can't read configurations, error -110
Aug 14 16:57:02 antec kernel: [  181.830425] usb 1-1.5: new full-speed USB device number 4 using ehci-pci
Aug 14 16:57:02 antec kernel: [  181.917487] usb 1-1.5: New USB device found, idVendor=04b0, idProduct=0114
Aug 14 16:57:02 antec kernel: [  181.917491] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Aug 14 16:57:02 antec kernel: [  181.917493] usb 1-1.5: Product: NIKON DSC E3100
Aug 14 16:57:02 antec kernel: [  181.917495] usb 1-1.5: Manufacturer: NIKON
Aug 14 16:57:02 antec kernel: [  181.917496] usb 1-1.5: SerialNumber: 000003205601
Aug 14 16:57:02 antec mtp-probe: checking bus 1, device 4: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5"
Aug 14 16:57:02 antec mtp-probe: bus: 1, device: 4 was not an MTP device
Aug 14 16:57:02 antec kernel: [  181.987157] Initializing USB Mass Storage driver...
Aug 14 16:57:02 antec kernel: [  181.992328] scsi16 : usb-storage 1-1.5:1.0
Aug 14 16:57:02 antec kernel: [  181.992607] usbcore: registered new interface driver usb-storage
Aug 14 16:57:02 antec kernel: [  181.992609] USB Mass Storage support registered.
Aug 14 16:57:03 antec kernel: [  182.994922] scsi 16:0:0:0: Direct-Access     NIKON    NIKON DSC E3100  1.00 PQ: 0 ANSI: 2
Aug 14 16:57:03 antec kernel: [  182.995598] sd 16:0:0:0: Attached scsi generic sg3 type 0
Aug 14 16:57:03 antec kernel: [  183.002162] sd 16:0:0:0: [sdb] 250880 512-byte logical blocks: (128 MB/122 MiB)
Aug 14 16:57:03 antec kernel: [  183.003546] sd 16:0:0:0: [sdb] Write Protect is off
Aug 14 16:57:03 antec kernel: [  183.004785] sd 16:0:0:0: [sdb] No Caching mode page present
Aug 14 16:57:03 antec kernel: [  183.004788] sd 16:0:0:0: [sdb] Assuming drive cache: write through
Aug 14 16:57:03 antec kernel: [  183.013283] sd 16:0:0:0: [sdb] No Caching mode page present
Aug 14 16:57:03 antec kernel: [  183.013288] sd 16:0:0:0: [sdb] Assuming drive cache: write through
Aug 14 16:57:03 antec kernel: [  183.022031]  sdb: sdb1
Aug 14 16:57:03 antec kernel: [  183.033261] sd 16:0:0:0: [sdb] No Caching mode page present
Aug 14 16:57:03 antec kernel: [  183.033265] sd 16:0:0:0: [sdb] Assuming drive cache: write through
Aug 14 16:57:03 antec kernel: [  183.033268] sd 16:0:0:0: [sdb] Attached SCSI removable disk
Aug 14 16:57:05 antec udisksd[1643]: Mounted /dev/sdb1 at /run/media/craig/1633-17F2 on behalf of uid 1000



Version-Release number of selected component (if applicable):
kernel 3.10.5-201.fc19.x86_64

How reproducible:
every time a connection is tried

Steps to Reproduce:
1. plug in camera with USB cable
2. turn on camera

Actual results:
no connection to camera made

Expected results:
camera connects

Additional info:
Comment 1 Josh Boyer 2013-09-18 16:43:40 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 2 Craig Goodyear 2013-09-19 08:40:52 EDT
Tested with kernel 3.11.1-200.fc19.x86_64. This bug is still there.
Comment 3 jonathan baron 2013-10-30 08:26:59 EDT
Also 3.11.6-200.fc19.x86_64

But there are huge problems everywhere, so I'm not sure that this is the right bug to comment on. I can no longer access a digital camera as "mass storage" to copy photos. (The only way that seems to work is to open the camera with caja, view the pictures one by one, and save each one, using eom.)

I cannot access an android (4.3.3) tablet either through mtpfs or simple-mtpfs or go-mtpfs, or, after converting the tablet to mass storage, through anything else. On the latter, /var/log/messages shows the following, repeatedly, over and over, changing the number each time. I used to be able to use simple-mtpfs reliably.

Oct 29 06:10:14 barber kernel: [33079.692105] hub 2-0:1.0: unable to enumerate USB device on port 8
Oct 29 06:10:14 barber kernel: [33079.921975] usb 8-2: new full-speed USB device number 2 using uhci_hcd
Oct 29 06:10:14 barber kernel: [33080.451681] usb 8-2: new full-speed USB device number 3 using uhci_hcd
Oct 29 06:10:15 barber kernel: [33080.987384] usb 8-2: new full-speed USB device number 4 using uhci_hcd
Oct 29 06:10:15 barber kernel: [33081.340190] usb 8-2: new full-speed USB device number 5 using uhci_hcd
Oct 29 06:10:16 barber kernel: [33081.592065] hub 8-0:1.0: unable to enumerate USB device on port 2
Oct 29 06:10:16 barber kernel: [33081.714982] usb 8-2: new full-speed USB device number 6 using uhci_hcd
Oct 29 06:10:16 barber kernel: [33082.248706] usb 8-2: new full-speed USB device number 7 using uhci_hcd
Oct 29 06:10:17 barber kernel: [33082.779323] usb 8-2: new full-speed USB device number 8 using uhci_hcd
Oct 29 06:10:17 barber kernel: [33083.132200] usb 8-2: new full-speed USB device number 9 using uhci_hcd
Comment 4 Peter Hatina 2013-12-06 04:41:00 EST
Ad your tablet: Please, check, if your vendor and product ID are present in libmtp header file music-players.h. If not, none of mentioned FUSE drivers will work.
Comment 5 jonathan baron 2013-12-06 06:25:03 EST
(In reply to Peter Hatina from comment #4)
> Ad your tablet: Please, check, if your vendor and product ID are present in
> libmtp header file music-players.h. If not, none of mentioned FUSE drivers
> will work.

music-players.h does not list any vendors or IDs. However, 69-libmtp-rules does list them, and it seems that my tablet (Nexus 10) is listed there:

# Google Inc (for LG Electronics/Samsung) Nexus 4/10 (MTP)
ATTR{idVendor}=="18d1", ATTR{idProduct}=="4ee1", SYMLINK+="libmtp-%k", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"
# Google Inc (for LG Electronics/Samsung) Nexus 4/10 (MTP+ADB)
ATTR{idVendor}=="18d1", ATTR{idProduct}=="4ee2", SYMLINK+="libmtp-%k", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"
Comment 6 Peter Hatina 2013-12-06 07:01:25 EST
music-players.h *do* list vendor and product ID's (see [1]) and your device needs to be included in that file in order to make libmtp work with your tablet.

Follow instructions stated in chapter "New Device?" at [2].

[1] http://sourceforge.net/p/libmtp/code/ci/HEAD/tree/src/music-players.h
[2] http://libmtp.sourceforge.net/
Comment 7 jonathan baron 2013-12-06 08:32:39 EST
Now I'm really confused. I thought that I had looked at music-players.h, but apparently I don't have it. I don't know what I looked at. It seems to be part of the source, which is not kept once libmtp is compiled. But the version of libmtp that I have has a listing on sourceforge, and it contains exactly the same information that I found in 69-libmtp-rules. Perhaps 69-libmtp-rules is compiled from music-players.h.

Anyway, just for fun, I upgraded the tablet to version 4.4 of Android and tried it again, with simple-mtpfs. I got the usual error message:

Device 0 (VID=18d1 and PID=4ee1) is a Google Inc (for LG Electronics/Samsung) Nexus 4/10 (MTP).
ignoring libusb_claim_interface() = -6PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device

But then I didn't do anything for a few seconds, and it actually succeeded in connecting. It has worked before like this, and then stopped working after some time, but perhaps it won't stop this time. We'll see.
Comment 8 Peter Hatina 2013-12-06 09:23:18 EST
Ah, I am glad, it works for you, now. I also see that kind of error messages, when mounting my Galaxy Nexus or Nexus 7 (libmtp stuff).
Comment 9 Justin M. Forbes 2014-01-03 17:04:58 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 10 Craig Goodyear 2014-01-04 11:00:24 EST
I have upgraded to Fedora 20.  Testing with latest kernel 3.12.6-300.fc20.x86_64 my camera is mounted successfully.
Comment 11 Michele Baldessari 2014-01-04 11:19:17 EST
Hi Craig,

thanks for confirming. Am closing this BZ.

regards,
Michele
Comment 12 jonathan baron 2014-01-04 11:24:06 EST
Works for me too on Fedora 19.

However, I still cannot connect to my Nexus 10 tablet with simple-mtpfs. I guess I'll either give up on that - even though it used to work - since I can now connect with ssh-server. I thought this was the same bug, but it isn't.

Note You need to log in before you can comment on or make changes to this bug.