Bug 997330 - installing openmpi without openmpi-devel installs undefined symlinks
installing openmpi without openmpi-devel installs undefined symlinks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openmpi (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 03:46 EDT by Jos de Kloe
Modified: 2013-08-16 12:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 12:05:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos de Kloe 2013-08-15 03:46:37 EDT
Description of problem:

after installing openmpi without openmpi-devel I noticed that the following symbolic links are installed and point to a not existing file:

  /usr/lib64/openmpi/bin/ortec++
  /usr/lib64/openmpi/bin/ortecc
  /usr/lib64/openmpi/bin/orteCC

if I then install openmpi-devel they become valid because then opal_wrapper becomes available.

Version-Release number of selected component (if applicable):

openmpi-1.6.5-1.fc19.x86_64
openmpi-devel-1.6.5-1.fc19.x86_64

How reproducible:

always

Steps to Reproduce:
1. install openmpi without openmpi-devel
2. check the mentioned symbolic links

Actual results:

dangling symlinks in /usr/lib64/openmpi/bin/

Expected results:

valid symbolic links or none at all.
These symlinks should probably be moved into openmpi-devel.

Additional info:
Comment 1 Orion Poplawski 2013-08-16 12:05:11 EDT
Fixed in:

openmpi-1.7.2-7.fc20
openmpi-1.6.5-3.fc19 - unbuilt - will go out with next bugfix update

Note You need to log in before you can comment on or make changes to this bug.