Bug 997372 - [fork][origin_ui_58]Can not filter out node which does not belong to any district using "(NONE)" option.
[fork][origin_ui_58]Can not filter out node which does not belong to any dist...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jessica Forrester
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 06:28 EDT by Yujie Zhang
Modified: 2015-05-14 21:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:51:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2013-08-15 06:28:59 EDT
Description of problem:

Removed a node from its district, and checking using "oo-stats -l node", it belongs to a "(NONE)" district, the display on admin console is also the same result, but when trying to filter the node using "(NONE)" option, got no result, and the node can be filtered out without choosing any district option.

Version-Release number of selected component (if applicable):
fork_ami_origin_ui_69_761

How reproducible:
always

Steps to Reproduce:
1.Remove a c9 node from its district
2.Check on the /admin-console/capacity/profiles/c9 page
3.Click the "1 node" link on the "(NONE)" district line
4.Check the result and choose the "Choose District" option in the filter

Actual results:

The node can not be filtered out using "(NONE)" option, but it can be filtered out using "Choose District"

Expected results:

Since we assumed the node belongs to "(NONE)" district, it should be able to filtered out using "(NONE)" district, so that the result can be consistant.

Additional info:
Comment 1 Jessica Forrester 2013-08-16 09:49:11 EDT
Fixed in fork_ami_origin_ui_69_772.  The (NONE) district should not have been showing up in the list when looking at the districts tab, that has been fixed as well.  When viewing the nodes tab the filter will now always have a dropdown item for "nodes not in a district".
Comment 2 Yujie Zhang 2013-08-19 04:12:12 EDT
Tested on fork_ami_origin_ui_69_772, the item "nodes not in a district" has been added and node which does not belong to any district can be filtered out using that item, so verify this bug, thanks!

Note You need to log in before you can comment on or make changes to this bug.