Bug 997379 - Wrong MOF files ordering
Wrong MOF files ordering
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openlmi-providers (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Novacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 06:53 EDT by Tomas Smetana
Modified: 2016-11-30 19:31 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 07:44:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Smetana 2013-08-15 06:53:02 EDT
Description of problem:
There are two MOFs being shipped with the openlmi-providers package:

05_LMI_Qualifiers.mof
30_LMI_Jobs.mof

The numbering prefix suggests the LMI_Qualifiers should be registered before the LMI_Jobs, however the reverse order is correct.

Version-Release number of selected component (if applicable):
penlmi-providers-0.1.1-1.fc20.x86_64

How reproducible:
Always

Steps to Reproduce:
Try to register the MOF files byt their number prefix to a newly installed CIMOM (sblim-sfcb in my case):

1. sfcbstage -n root/cimv2 /usr/share/openlmi-providers/05_LMI_Qualifiers.mof
2. sfcbrepos -f

Actual results:

error in /var/lib/sfcb/stage/mofs/indication.mof line 34 near CIM_System: class LMI_ConcreteJob was referenced but never defined.
error in /var/lib/sfcb/stage/mofs/indication.mof line 34 near CIM_System: class LMI_OwningJobElement was referenced but never defined.
error in /var/lib/sfcb/stage/mofs/indication.mof line 34 near CIM_System: class LMI_OwningNetworkJobElement cannot be association, since parent LMI_OwningJobElement is none
error in /var/lib/sfcb/stage/mofs/indication.mof line 34 near CIM_System: class LMI_AffectedJobElement was referenced but never defined.
error in /var/lib/sfcb/stage/mofs/indication.mof line 34 near CIM_System: class LMI_AffectedNetworkJobElement cannot be association, since parent LMI_AffectedJobElement is none
Failed compiling the MOF files

Expected results:
The MOFs get registered cleanly
Comment 1 Radek Novacek 2013-08-15 07:05:23 EDT
The 05_LMI_Qualifiers.mof file doesn't contain anything that is specified in the 30_LMI_Jobs.mof. Contrary, 30_LMI_Jobs.mof uses Implemented qualifier that is defined in the 05_LMI_Qualifiers.mof.

The ordering of these two files is correct.

The error is caused by something else, probably some error in registration to sfcbd.
Comment 2 Tomas Smetana 2013-08-15 07:30:27 EDT
Might be. However registering the two in reverse order worked OK for me... I'll take a closer look.
Comment 3 Tomas Smetana 2013-08-15 07:44:03 EDT
The buggy one is the reporter... There was and old /var/lib/sfcb directory containing various remains of random stuff prior the sblim-sfcb installation which got mixed with the new registration.

Note You need to log in before you can comment on or make changes to this bug.