Bug 997386 - ClassNotFoundException while trying to perform any REST API operation
ClassNotFoundException while trying to perform any REST API operation
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Mark Proctor
Ivo Bek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 07:15 EDT by Ivo Bek
Modified: 2014-08-06 16:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:16:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-08-15 07:15:49 EDT
Description of problem:

It's not possible to perform any REST API operation such as clone of repository. Any attempt will cause ClassNotFoundException for org.kie.workbench.common.services.rest.BasicAuthentication which is located in web.xml.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Prakash Aradhya 2013-08-19 05:52:35 EDT
If this is related to managing repository content through REST, it is OK not to have it working for Beta.
Comment 2 Ivo Bek 2013-08-19 06:14:59 EDT
No, this exception is general for both, the managing REST API and REST API for execution server.
Comment 3 Rajesh Rajasekaran 2013-08-19 09:01:11 EDT
Changing pm_ack based on QE's last comment. Also setting the blocker flag. Can somebody from dev take a look?
Comment 4 lcarlon 2013-08-20 02:28:53 EDT
Marked as requiring docs text as it sounds like we will need to let Beta users know this isn't working.
Comment 5 Jervis Liu 2013-08-20 02:56:19 EDT
Can not reproduce on 6.0.x branch. Which version was used for this test report?
Comment 6 Ivo Bek 2013-08-20 03:04:39 EDT
I used the first BPMS 6.0 ER1.
Comment 7 Jervis Liu 2013-08-20 03:53:57 EDT
I see.  ER1 was built using a version of 6.0.x on 6th Aug. This problem had been fixed on the same day.
Comment 8 Ivo Bek 2013-09-09 05:00:13 EDT
Verified in BPMS 6.0.0.ER2

Note You need to log in before you can comment on or make changes to this bug.