Bug 997398 - unable to compile module
unable to compile module
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 08:09 EDT by Mike Heller
Modified: 2013-08-16 03:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 03:13:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Heller 2013-08-15 08:09:55 EDT
Description of problem:

I'm trying to compile the kernel module for "CP210x USB to UART Bridge VCP Drivers" from silabs because there is a missing device without success.


Version-Release number of selected component (if applicable):

3.10.5-201.fc19.i686.PAE

How reproducible:

try to compile the module with make

Steps to Reproduce:
1. download the software from silabs
2. try to compile the module with make
3.

Actual results:

make -C /lib/modules/3.10.5-201.fc19.i686.PAE/build M= modules
make[1]: Entering directory `/usr/src/kernels/3.10.5-201.fc19.i686.PAE'
make[2]: *** Keine Regel vorhanden, um das Target »/usr/src/kernels/3.10.5-201.fc19.i686.PAE/arch/x86/syscalls/syscall_32.tbl«, 
  benötigt von »arch/x86/syscalls/../include/generated/uapi/asm/unistd_32.h«, zu erstellen.  Schluss.
make[1]: *** [archheaders] Fehler 2
make[1]: Leaving directory `/usr/src/kernels/3.10.5-201.fc19.i686.PAE'
make: *** [all] Fehler 2


Expected results:

the compiled module

Additional info:
Comment 1 Mike Heller 2013-08-16 03:13:11 EDT
I got it to work while downloading the source of the current kernel.

sorry about.

Note You need to log in before you can comment on or make changes to this bug.