Bug 997403 - Error message instructs users to invoke 'yum' rather than 'dnf' to fix a problem
Error message instructs users to invoke 'yum' rather than 'dnf' to fix a problem
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 08:28 EDT by Daniel Berrange
Modified: 2014-09-30 19:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: dnf-0.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 06:53:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2013-08-15 08:28:09 EDT
Description of problem:
When I ran 'dnf update' today, it downloaded all packages and then exited with the following error messages:

Error Downloading Packages:
  libreoffice-opensymbol-fonts-1:4.1.0.4-6.fc19.noarch: Package does not match intended download. Suggestion: run yum --enablerepo=updates clean metadata
  python3-3.3.2-5.fc19.x86_64: Package does not match intended download. Suggestion: run yum --enablerepo=updates clean metadata
  libreoffice-pyuno-1:4.1.0.4-6.fc19.x86_64: Package does not match intended download. Suggestion: run yum --enablerepo=updates clean metadata
  ....cut more of the same...


Presumably this ought to be telling me to run 'dnf', not 'yum' to fix the problem.

Version-Release number of selected component (if applicable):
dnf-0.3.10-1.giteb9dddb.fc19.noarch

How reproducible:
Unknown - not sure how I even got into this problem scenario with metadata brokenness :-)
Comment 1 Ales Kozumplik 2013-08-16 06:37:53 EDT
Hi, thanks for reporting this, trivially fixed by e65e5ce. The metadata error itself is what's bothering me here, I've added a logline in 27fe410 so we can tell more if you see it again.

Note You need to log in before you can comment on or make changes to this bug.