Bug 997405 - not possible to quit initial screen in text mode
not possible to quit initial screen in text mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Samantha N. Bueno
Release Test Team
:
: 951116 1030516 1060694 (view as bug list)
Depends On:
Blocks: 782468 1024955 1028479 1090148
  Show dependency treegraph
 
Reported: 2013-08-15 08:38 EDT by Jan Tluka
Modified: 2015-03-05 08:55 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-19.31.90-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1090148 (view as bug list)
Environment:
Last Closed: 2015-03-05 08:55:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (972.09 KB, image/bmp)
2014-01-20 08:45 EST, IBM Bug Proxy
no flags Details
Quit the initial screen during the installation (80.07 KB, application/vnd.oasis.opendocument.text)
2014-12-12 06:10 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description Jan Tluka 2013-08-15 08:38:53 EDT
Description of problem:

The first screen of the installer provides option to quit installation ('q'). But when I enter 'q' the installation won't quit but instead the same screen is shown.

Starting installer, one moment...
anaconda 19.30.13-1 for Red Hat Enterprise Linux 7.0 (pre-release) started.
================================================================================
================================================================================
VNC

Text mode provides a limited set of installation options. It does not allow you 
to specify your own partitioning layout or package selections. Would you like to
 use VNC mode instead?

 1) Start VNC

 2) Use text mode

  Please make your choice from above ['q' to quit | 'c' to continue |
  'r' to refresh]: q
================================================================================
================================================================================
VNC

Text mode provides a limited set of installation options. It does not allow you 
to specify your own partitioning layout or package selections. Would you like to
 use VNC mode instead?

 1) Start VNC

 2) Use text mode

  Please make your choice from above ['q' to quit | 'c' to continue |
  'r' to refresh]:

Version-Release number of selected component (if applicable):
RHEL-7.0-20130628.0


How reproducible:
everytime

Steps to Reproduce:
1. virt-install -n rhel7-2 -r 1000 --vcpus 2 --location http://download/pub/rhel/rel-eng/RHEL-7.0-20130628.0/compose/Server/x86_64/os/ -x "console=ttyS0" --disk path=/var/lib/libvirt/images/rhel7-2.img,size=5 -w network=default --hvm --graphics none --virt-type=kvm -d
2. once prompted for text mode/VNC installation press 'q'
3.

Actual results:
Selection ignored

Expected results:
Installation is aborted (eventually prompt for confirmation)

Additional info:
Comment 1 David Cantrell 2013-12-16 15:42:17 EST
That's a generic prompt with commands used throughout the text mode installer.  We can revisit changing up some of the wordings in 7.1.
Comment 2 Samantha N. Bueno 2014-01-20 08:38:44 EST
*** Bug 1030516 has been marked as a duplicate of this bug. ***
Comment 3 IBM Bug Proxy 2014-01-20 08:45:33 EST
Created attachment 852739 [details]
Screenshot

default comment by bridge
Comment 4 Jan Stodola 2014-02-03 07:37:01 EST
*** Bug 1060694 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2014-02-26 15:51:45 EST
*** Bug 951116 has been marked as a duplicate of this bug. ***
Comment 6 IBM Bug Proxy 2014-03-07 05:01:04 EST
------- Comment From machihin_a@ru.ibm.com 2014-03-07 09:57 EDT-------
upd: also reproduced in snap9.
Comment 8 Alexander Todorov 2014-11-12 04:55:52 EST
Verifid with 1111.0 build. I'm able to quit the installer and the system reboots.
Comment 9 IBM Bug Proxy 2014-12-12 06:10:44 EST
Created attachment 967576 [details]
Quit the initial screen during the installation


------- Comment (attachment only) From SSULZMAN@de.ibm.com 2014-12-12 11:06 EDT-------
Comment 11 errata-xmlrpc 2015-03-05 08:55:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0312.html

Note You need to log in before you can comment on or make changes to this bug.