Bug 997543 - Wine 1.5.29 broken icons after installation
Wine 1.5.29 broken icons after installation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 946881 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 10:31 EDT by Ali Akcaagac
Modified: 2013-09-06 01:06 EDT (History)
5 users (show)

See Also:
Fixed In Version: wine-1.7.1-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 21:29:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GNOME Shell shows crappy Wine 1.5.29 icons (55.81 KB, image/jpeg)
2013-08-15 10:31 EDT, Ali Akcaagac
no flags Details
spec file patch (against git head), to fix icon generation (3.55 KB, patch)
2013-08-23 05:55 EDT, "FeRD" (Frank Dana)
no flags Details | Diff
offline patch for already installed wine based on FeRD's patch (930 bytes, application/x-shellscript)
2013-08-24 07:30 EDT, Ali Akcaagac
no flags Details

  None (edit)
Description Ali Akcaagac 2013-08-15 10:31:14 EDT
Created attachment 786958 [details]
GNOME Shell shows crappy Wine 1.5.29 icons

I detected an issue with Wine 1.5.29 (and a few earlier versions as well) that nearly all icons created by Wine are broken. Even after creating a new user accound and totally fresh installation of Wine 1.5.29 the icons still look crappy. Please have a look at the provided screenshot.
Comment 1 "FeRD" (Frank Dana) 2013-08-23 05:55:49 EDT
Created attachment 789532 [details]
spec file patch (against git head), to fix icon generation

[NOTE: PATCH PROVIDED]

This bug is due to the fact that the wine icons are distributed as composite SVG files, containing multiple icon sizes. The wine distribution comes with a tool to output .ICO and .BMP files, but not to extract single .SVG icons.

The specfile that packages wine attempts to perform some sed(1) dark magic on the composite SVG source files, in order to mask them down to just the scalable icon image. Unfortunately, that code was written two years ago, and since then the source files for program icons (only!) have changed — to include larger icon sizes — but the dark magic hasn't. As a result, the sed expressions fail, the .SVG files are installed unmodified, and as a result... well, you've seen the result.

The attached patch, against wine.spec from the current git HEAD, fixes the dark magic for program icons and causes them to be installed properly.

The patch is slightly fugly, and I'm a bit embarrassed by it, but it merely continues on with the same logic that was previously in place in the spec file. (Actually, it's a tiny bit cleaner, because it at least matches against entire attribute strings in the XML file, rather than just blindly replacing bare integers wherever it finds them.)

Still, the dark-magic sed expression is significantly nastier now. This is a necessary consequence of the fact that the new .svg layout places the scalable icon at the far right of the canvas. This necessitates the addition of a viewBox attribute to the SVG structure, in addition to width/height adjustments. Still, I tried to keep the replacement as concise as I could while still properly formatting the additions within the output code.

On my system, a set of wine rpms built off this patched spec file (actually, I backported it to the released 1.6 as well) fix all of the "weird" wine icon problems. Hopefully one of the wine maintainers will be able to look it over, and consider applying it to the official package spec so that new wine packages can be generated with the proper icons? Thanks.
Comment 2 Ali Akcaagac 2013-08-24 07:29:13 EDT
Yes, this patch above solved the issue for me. I took the patch from FeRD and made an offline version to apply on an already installed Wine. The icons show up as expected now. I suggest updating "wine-desktop".
Comment 3 Ali Akcaagac 2013-08-24 07:30:10 EDT
Created attachment 789814 [details]
offline patch for already installed wine based on FeRD's patch
Comment 4 Andreas Bierfert 2013-08-31 11:06:20 EDT
*** Bug 946881 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-09-01 15:48:48 EDT
wine-1.7.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wine-1.7.1-2.fc19
Comment 6 Fedora Update System 2013-09-02 19:32:17 EDT
Package wine-1.7.1-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wine-1.7.1-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15685/wine-1.7.1-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-09-04 21:29:43 EDT
wine-1.7.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Ali Akcaagac 2013-09-06 01:06:20 EDT
Just for clearification. The bugreport was opened for Fedora 18 but got resolved and closed for Fedora 19. The problem still exists for people still using Fedora 18. I for now solved it by applying FeRD's patch locally. Maybe an update of wine-desktop for Fedora 18 should fix this as well ?

Note You need to log in before you can comment on or make changes to this bug.