Bug 997548 - Error in Translaction Check in yum update (FC 17)
Error in Translaction Check in yum update (FC 17)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 10:52 EDT by Anne Mahoney
Modified: 2013-08-16 02:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 02:53:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from "yum update kdenetwork-common" showing error in transaction check (53.25 KB, text/plain)
2013-08-15 10:52 EDT, Anne Mahoney
no flags Details

  None (edit)
Description Anne Mahoney 2013-08-15 10:52:24 EDT
Created attachment 786961 [details]
output from "yum update kdenetwork-common" showing error in transaction check

I'm trying to upgrade from 17 to 19 (cf. bug 980543).  I figured I should make sure 17 was all correct first;  I've upgraded from 13 -> 15 -> 17 this week and there may be some cruft around.

I ran package-cleanup and saw this:

Package 7:kdenetwork-common-4.8.3-1.fc17.noarch has installed conflicts kdenetwork < ('7', '4.6.95', '10'): 7:kdenetwork-4.6.2-2.fc15.i686

so did 

yum update kdenetwork-common

Yum proposed to update 40 dependencies (!!), so I said it was OK.  It then proceeded to install the packages and ended up with:

Total                                           3.1 MB/s |  19 MB     00:06     
Running Transaction Check
ERROR with transaction check vs depsolve:
xz = 4.999.9-0.2.beta.20091007git.fc13 is needed by (installed) xz-lzma-compat-4.999.9-0.2.beta.20091007git.fc13.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 132 pre-existing rpmdb problem(s), 'yum check' output follows:

So I am reporting it.  I'm not sure why it says to report it against "rawhide," given that I'm running FC 17.  I realize problems aren't getting fixed in that release, but is there a known workaround?

I have attached the entire output.
Comment 1 Jan Zeleny 2013-08-16 02:53:10 EDT
I'm sorry but in this case the message to report the bug is not supposed to be there, it's a leftover from older days - this is not a bug of yum, it just reported you a broken state of your system.

One of the problems I can see is the xz-lzma-compat package, you need to uninstall it. Of course there is the other issue that yum tells you - you have 132 pre-existing rpmdb problems (see the output of yum check), you will need to take care of them in a similar way.

Note You need to log in before you can comment on or make changes to this bug.