Bug 997596 - XEN hvm guests do not honor VNC domain configuration
XEN hvm guests do not honor VNC domain configuration
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 13:44 EDT by Carl Roth
Modified: 2013-12-16 14:58 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 14:58:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Roth 2013-08-15 13:44:10 EDT
Description of problem:

When I create an HVM XEN guest with libvirt (virsh, virt-install) the resulting domain does not honor the VNC configuration settings in the domain XML config.  Rather, the domain comes up listening to 127.0.0.1:5900.

Version-Release number of selected component (if applicable):

libvirt-1.1.0-1.fc18.x86_64
xen-4.2.2-10.fc18.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Here are the relevant snippets from my domain config:

<domain type='xen' id='8'>
  <name>xen-d975xbx-xp</name>
  <uuid>1fe4a1c7-d4dd-05d8-c442-083ead3308b3</uuid>
  <memory unit='KiB'>2097152</memory>
  <currentMemory unit='KiB'>2097152</currentMemory>
  <vcpu placement='static'>1</vcpu>
  <os>
    <type arch='x86_64' machine='xenfv'>hvm</type>
    <loader>/usr/lib/xen/boot/hvmloader</loader>
    <boot dev='hd'/>
    <boot dev='cdrom'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
...
    <input type='tablet' bus='usb'/>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='5905' autoport='no' listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
    </graphics>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
    </video>
    <memballoon model='xen'/>
  </devices>
</domain>

When the domain starts, it listens for VNC on localhost:5900, which would imply that the VNC descriptor ignored, instead perceived as

    <graphics type='vnc' port='-1' autoport='yes' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
    </graphics>

Additional info:
Comment 1 Carl Roth 2013-08-15 13:46:48 EDT
Note that 'virsh domxml-to-native' when run on this domain's XML description yields

...
vnc = 1
vncunused = 0
vncdisplay = 5
vnclisten = "0.0.0.0"
...
Comment 2 Cole Robinson 2013-12-16 14:58:43 EST
Looks like you are using a virt-preview libvirt version on F18. That version isn't available or supported anymore. Please try updating to F19+ and seeing if this issue still reproduces, either with stock packages or fedora-virt-preview, and if so reopen this bug

Note You need to log in before you can comment on or make changes to this bug.