Bug 997614 - unable to specify timezone with local time
unable to specify timezone with local time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 15:21 EDT by Gene Czarcinski
Modified: 2013-08-15 15:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 15:32:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2013-08-15 15:21:33 EDT
Description of problem:
According to the comments in https://bugzilla.redhat.com/show_bug.cgi?id=881403 you should be able to have local time if you do NOT specify Uts on the kickstart timezone command [there is currently no way to do it from the gui].  Maybe it should be working that way but it is not.

Version-Release number of selected component (if applicable):
Release 19, anaconda 19.30.13-1.fc19

How reproducible:
everytime

Steps to Reproduce:
1.do a kickstart install for a minimal system
2.
3.

Actual results:
/etc/adjtime has UTC

The anaconda-ks.cfg file in /root has
timezone America/New_York --isUtc

Expected results:
/etc/adjtime has LOCAL

The anaconda-ks.cfg file in /root has
timezone America/New_York

Additional info:


Yes, I know the using UTC is the "right thing to do" but ... that is your opinion.  The ability to specify whether Utc or local time was to be used has been an option in Red Hat Linux and then Fedora for a long, long time.  What is the justification for removing that option and forcing UTC???
Comment 1 David Shea 2013-08-15 15:32:54 EDT
The problem is fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.