Bug 997616 - Unable to view the users after the sam 1.3 upgrade
Unable to view the users after the sam 1.3 upgrade
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Tom McKay
sthirugn@redhat.com
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-15 15:31 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:19:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
undefine method error screenshot (31.51 KB, image/png)
2013-08-15 15:32 EDT, sthirugn@redhat.com
no flags Details
production.log (124.38 KB, text/plain)
2013-08-15 15:35 EDT, sthirugn@redhat.com
no flags Details

  None (edit)
Description sthirugn@redhat.com 2013-08-15 15:31:23 EDT
Description of problem:
After sam 1.3 upgrade, clicking on users throws error

Version-Release number of selected component (if applicable):
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install SAM 1.2.1 from RHN. Create couple of users and associate them to environments
2. Run SAM 1.3 upgrade
3. After the upgrade log into SAM Web UI -> Administer -> Users -> Click on any user

Actual results:
A user error thrown: (screenshot attached)
    undefined method `id' for nil:NilClass (NoMethodError)
    Click here for more details.

Expected results:
The user details shown

Additional info:
This happens only for the users which were created before the upgrade.  The users created after the upgrade works fine.
Comment 1 sthirugn@redhat.com 2013-08-15 15:32:39 EDT
Created attachment 787030 [details]
undefine method error screenshot
Comment 2 sthirugn@redhat.com 2013-08-15 15:35:30 EDT
Created attachment 787032 [details]
production.log
Comment 3 Bryan Kearney 2013-08-28 13:11:59 EDT
Lates build (Snap4) should contain these fixes. Please test on Snap4.
Comment 4 sthirugn@redhat.com 2013-08-30 17:39:11 EDT
VERIFIED.

Version Tested:

* candlepin-0.8.24-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.24-1.el6sam.noarch
* candlepin-tomcat6-0.8.24-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-9.el6sat.noarch
* katello-cli-common-1.4.3-9.el6sat.noarch
* katello-common-1.4.3-11.el6sam_splice.noarch
* katello-configure-1.4.4-3.el6sat.noarch
* katello-glue-candlepin-1.4.3-11.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-11.el6sam_splice.noarch
* katello-headpin-1.4.3-11.el6sam_splice.noarch
* katello-headpin-all-1.4.3-11.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 6 errata-xmlrpc 2013-10-01 07:19:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.