Bug 997634 - New roles created automatically in sam 1.3 upgrade
New roles created automatically in sam 1.3 upgrade
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Tom McKay
Hayk Hovsepyan
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-15 16:26 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:19:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Roles UI error (54.03 KB, image/png)
2013-08-15 16:27 EDT, sthirugn@redhat.com
no flags Details
production.log (31.23 KB, text/plain)
2013-08-15 16:28 EDT, sthirugn@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1390 normal SHIPPED_LIVE Release 1.3 of Subscription Asset Manager 2013-10-01 10:43:14 EDT

  None (edit)
Description sthirugn@redhat.com 2013-08-15 16:26:38 EDT
Description of problem:
New roles created automatically in sam 1.3 upgrade

Version-Release number of selected component (if applicable):
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install SAM 1.2.1 from RHN. Create couple of users and associate them to environments. Do not create any roles though.
2. Run SAM 1.3 upgrade
3. After the upgrade log into SAM Web UI -> Administer -> Roles

Actual results:
New roles are automatically created - clicking on which an UI user message is thrown (screenshot attached)

Expected results:
Upgrade should not create new roles.

Additional info:
Comment 1 sthirugn@redhat.com 2013-08-15 16:27:40 EDT
Created attachment 787052 [details]
Roles UI error
Comment 2 sthirugn@redhat.com 2013-08-15 16:28:01 EDT
Created attachment 787053 [details]
production.log
Comment 4 Tom McKay 2013-08-20 09:07:27 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 05a575ec64f3569f1275900ae7c4f1e3efb93735
      https://github.com/Katello/katello/commit/05a575ec64f3569f1275900ae7c4f1e3efb93735
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-08-20 (Tue, 20 Aug 2013)
Comment 8 errata-xmlrpc 2013-10-01 07:19:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.