Bug 997643 - realm join in kickstart doesn't work
realm join in kickstart doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
:
: 1025290 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 17:00 EDT by Lorenzo Keller
Modified: 2014-01-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version: lorax-19.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-30 17:11:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update for anaconda with the missing libraries (93.07 KB, application/x-gzip)
2013-08-15 17:00 EDT, Lorenzo Keller
no flags Details

  None (edit)
Description Lorenzo Keller 2013-08-15 17:00:30 EDT
Created attachment 787058 [details]
update for anaconda with the missing libraries

Description of problem:

Kickstart with "realm join" fails because realmd cannot be started on the squashfs image. The daemon cannot be started because the library /usr/lib64/liblzo2.so.2 is missing from the squashfs image.

How reproducible:

Always

Steps to Reproduce:
1. Add the option realm join SOME.DOMAIN.COM to the kickstart file
2. Start installation using the kickstart file

Actual results:

The machine doesn't get enrolled to the realm. Log on console 3 shows a DBUS error.

Expected results:

The machine is enrolled to the realm.

Additional info:

I attach an updates.img file that fixes the problem.
Comment 1 David Shea 2013-08-16 10:43:15 EDT
Pushed the patch to keep liblzo2 on the install media. Thanks for finding this.
Comment 2 David Cantrell 2013-11-04 08:59:15 EST
*** Bug 1025290 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.