Bug 997667 - Thread pool creation fails due to optional parameter keepalive-time sending empty data
Summary: Thread pool creation fails due to optional parameter keepalive-time sending e...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.1.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER05
: JON 3.3.0
Assignee: Stefan Negrea
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-16 00:00 UTC by Larry O'Leary
Modified: 2015-09-03 00:01 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 13:59:21 UTC


Attachments (Terms of Use)
thread_pool_null_keepalive (169.89 KB, image/png)
2014-10-24 11:49 UTC, Armine Hovsepyan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 825384 None None None Never
Red Hat Bugzilla 997665 None None None Never
Red Hat Bugzilla 997669 None None None Never
Red Hat Bugzilla 998058 None None None Never
Red Hat Bugzilla 998673 None None None Never
Red Hat Bugzilla 1033404 None None None Never

Internal Trackers: 825384 997665 997669 998058 998673 1033404

Description Larry O'Leary 2013-08-16 00:00:35 UTC
Description of problem:
Creation of a thread pool fails with the error JBAS014746: unit may not be null, rolled-back=true.

Version-Release number of selected component (if applicable):
4.4.0.JON312GA

How reproducible:
Always

Steps to Reproduce:
1.  Install, configure, and start EAP 6 standalone server.
2.  Start JBoss ON system.
3.  Import EAP 6 standalone server into inventory.
4.  Configure EAP resource's connection properties.
5.  Create a new *thread pool* with the minimum set of required properties for the EAP resource:

    Navigate to *JBossAS7 Standalone Servers / EAP (127.0.0.1:9990)* and right-clicking on *thread > Create Child -> Thread Pool*:

        *New Resource Name*: `TestBoundedPool`
        *Resource Configuration Template*: `Bounded Queue Thread Pool`
        *Max Threads*: `10`


Actual results:
Thread pool creation fails with the error and report the following error on the child history page:

    JBAS014746: unit may not be null, rolled-back=true

Expected results:
Thread pool creation should be successful and the defaults should be applied for keepalive-time.

Additional info:
keepalive-time is defined as:

                        "keepalive-time" => {
                            "type" => OBJECT,
                            "description" => "Used to specify the amount of time that pool threads should be kept running when idle; if not specified, threads will run until the executor is shut down.",
                            "expressions-allowed" => false,
                            "nillable" => true,
                            "value-type" => {
                                "time" => {
                                    "type" => LONG,
                                    "description" => "The time",
                                    "expressions-allowed" => true,
                                    "nillable" => false
                                },
                                "unit" => {
                                    "type" => STRING,
                                    "description" => "The time unit",
                                    "expressions-allowed" => true,
                                    "nillable" => false
                                }
                            },
                            "access-type" => "read-write",
                            "storage" => "configuration",
                            "restart-required" => "no-services"
                        }

Because it is nillable, it is optional and therefore, not required:

/subsystem=threads/bounded-queue-thread-pool=MyThreadPool:add(max-threads=10,queue-length=100)
{"outcome" => "success"}

Comment 1 Larry O'Leary 2013-08-19 18:39:54 UTC
I am adding 825384 to the See Also list however this is actually partially duplicated in the original BZ. I have left them separate because 825384 contained other unrelated issues/topics to this BZ. 

I suggest that 825384 be closed as out-of-date and this BZ along with 998673 be used to capture what 825384 was originally attempting to capture.

Comment 3 Jay Shaughnessy 2014-09-03 20:29:13 UTC
This was fixed in upstream Bug 824818. Setting to ON_QA.

Comment 5 Simeon Pinder 2014-09-29 08:12:34 UTC
Moving into ER05 as didn't make the ER04 cut.

Comment 6 Jay Shaughnessy 2014-10-07 19:37:07 UTC
I believe I fixed this already as part of Bug 1033404.  Setting back to MODIFIED for ER05.

Comment 7 Jay Shaughnessy 2014-10-08 17:19:54 UTC
An additional commit that extends the plugin descriptor fixes in Bug 1033404 to more instances of keepalive-time.

master commit 57bc74e437be095db90805d4bc7913ad9a11cda7
Author: Stefan Negrea <snegrea@redhat.com>
Date:   Tue Oct 7 22:00:19 2014 -0500



release/jon3.3.x commit a4d97f62fc6f93659e0d83f0021fb1cdb3decbd6
Author: Stefan Negrea <snegrea@redhat.com>
Date:   Tue Oct 7 22:00:19 2014 -0500

    (cherry picked from commit 57bc74e437be095db90805d4bc7913ad9a11cda7)
    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>

Comment 9 Simeon Pinder 2014-10-21 20:24:07 UTC
Moving to ON_QA as available to test with the latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=394734

Comment 10 Armine Hovsepyan 2014-10-24 11:49:31 UTC
Created attachment 950356 [details]
thread_pool_null_keepalive

Comment 11 Armine Hovsepyan 2014-10-24 11:50:09 UTC
verified in JON 3.3 ER05
screen-shot attached


Note You need to log in before you can comment on or make changes to this bug.