Bug 997682 - publican fails if wkhtmltopdf is installed
publican fails if wkhtmltopdf is installed
Status: CLOSED CANTFIX
Product: Publican
Classification: Community
Component: publican (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity unspecified
: 4.1
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 22:12 EDT by Peter Hutterer
Modified: 2014-02-27 18:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-27 18:53:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hutterer 2013-08-15 22:12:58 EDT
Description of problem:
3.1.5-3 dropped wkhtmltopdf in favour of fop but still calls wkhtmltopdf if it is available. -3 dropped the patch that removed the arguments that require a patched version of QT (--header-spacing, etc.), so now publican FTBFS or FTB anything.

Version-Release number of selected component (if applicable):
publican-3.1.5-3

How reproducible:
try rebuilding publican itself with wkhtmltopdf installed

Actual results:
error message (multiple times):
The switch --header-spacing, is not support using unpatched qt, and will be ignored.The switch --footer-spacing, is not support using unpatched qt, and will be ignored.The switch --header-html, is not support using unpatched qt, and will be ignored.The switch --footer-html, is not support using unpatched qt, and will be ignored.The switch --xsl-style-sheet, is not support using unpatched qt, and will be ignored.wkhtmltopdf: cannot connect to X server 

wkhtmltopdf died, PDF generation failed. Check log for details.
 at /home/whot/fedora/git/publican/Publican-v3.1.5/blib/script/publican line 921.

Expected results:
no error message, but some soothing confirmation that everything went well, we can reduce the threat level, turn off the alarm and generally go on with our lives. oh, and a build of the documentation would be nice too. and a pony.

Additional info:
Looks like bug 953728.
Comment 1 Peter Hutterer 2013-08-15 22:22:56 EDT
restoring nopdfcover.patch is sufficient to work around it though it then still dynamically picks wkhtmltopdf instad of fop.
Comment 2 Ruediger Landmann 2013-08-15 23:44:34 EDT
Even with nopdfcover.patch in place, the wkhtmltopdf output was unusable. Fortunately, Publican 3.2 allows you to specify the PDF engine, so I'll rebase on that.
Comment 3 Stephen Gordon 2013-09-18 13:25:41 EDT
Publican version to rebase is now 3.2.1.
Comment 4 Stephen Gordon 2013-09-18 13:27:26 EDT
Nevermind, I see this is now in updates-testing.
Comment 5 Jeff Fearn 2014-02-27 18:53:12 EST
From the wkhtmltopdf help page:

  Currently the list of features only supported with patch QT includes:

 * Printing more then one HTML document into a PDF file.
 * Running without an X11 server.
 * Adding a document outline to the PDF file.
 * Adding headers and footers to the PDF file.
 * Generating a table of contents.
 * Adding links in the generated PDF file.
 * Printing using the screen media-type.
 * Disabling the smart shrink feature of webkit.

It is not possible for us to get this X11 dep resolved with an unpatched QT.

Systems wishing to build books in environments without the patched QT or an X11 server should use the --pdftool option.

e.g.

$ publican build --langs en-US --pdftool fop --formats html,pdf,txt

Note You need to log in before you can comment on or make changes to this bug.