Bug 997712 - Ctrl key misbehaves on Sign Up screen
Ctrl key misbehaves on Sign Up screen
Status: CLOSED WORKSFORME
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: zanata-dev-internal
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 00:12 EDT by Damian Jansen
Modified: 2014-03-04 21:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 21:08:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-08-16 00:12:24 EDT
Description of problem:
The sign up screen does not handle the Ctrl key correctly. It seems to pass it to the page rather than handle it in the fields.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Easy always

Steps to Reproduce:
1. Go to $server/zanata/account/register
2. Focus the Name field
3. Hold Ctrl and press A

Actual results:
Whole page text is selected.

Expected results:
Name field text is selected, if any

Additional info:
Comment 1 Luke Brooker 2013-08-16 01:34:34 EDT
This doesn't seem to be a problem on Mac. Could be because it doesn't use CTRL for select all, but CMD instead.

CTRL + A Doesn't select the whole page either though.
Comment 2 Alex Eng 2013-09-18 17:51:15 EDT
Can't reproduce the issue with Chrome(29.0.1547.65) and Firefox(23.0.1). 
Need more info in browser version and os used.
Comment 3 Damian Jansen 2013-09-19 22:15:53 EDT
RHEL 6.3
Kernel 2.6.32-333
Gnome 2.28.2

Chrome: 24.0.1312.57
Firefox: 17.0.5

Perhaps not an issue on a more current browser?
Comment 4 Damian Jansen 2014-03-04 21:08:00 EST
No longer a problem

Note You need to log in before you can comment on or make changes to this bug.