Bug 997764 - ISS related configuration should be preserved during upgrade
ISS related configuration should be preserved during upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
560
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Martin Minar
:
Depends On:
Blocks: sat560-upgrades
  Show dependency treegraph
 
Reported: 2013-08-16 03:51 EDT by Jan Hutař
Modified: 2016-07-03 20:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: rhn-upgrade-5.6.0.29-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 15:25:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-08-16 03:51:36 EDT
Description of problem:
When you have either ISS slaves and/or ISS master configured (directives disable_iss, iss_parent, iss_ca_chain, allowed_iss_slaves) and functional in /etc/rhn/rhn.conf on 5.5.0 or below and you upgrade, settings should be transfered to DB, removed from rhn.conf and ISS should work same as before.


Version-Release number of selected component (if applicable):
Satellite-5.6.0-RHEL6-re20130812.0


Steps to Reproduce:
1. Configure ISS (both default master (iss_parent) and allowed slaves
   (allowed_iss_slaves)) in pre 5.6.0 Satellite
2. Make sure it works
3. Upgrade Satellite to 5.6.0
4. Make sure it works
5. Make sure settings are present in DB (Admin -> ISS Configuration) and *not*
   in the rhn.conf


Actual results:
Unknown


Expected results:
Make sure ISS works after upgrade and settings are present in DB (Admin -> ISS Configuration) and *not* in the rhn.conf.


Additional info:
Thanks tlestach to mentioning this!
Comment 9 Clifford Perry 2013-10-01 15:25:15 EDT
Satellite 5.6 has been released. This bug tracked under Upgrades. 

This bug either was VERIFIED or RELEASE_PENDING (re-verified prior shortly before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1393.html

Note You need to log in before you can comment on or make changes to this bug.