Bug 997794 - Bad HornetQ version in console log
Bad HornetQ version in console log
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Build, HornetQ (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity high
: ER7
: EAP 6.1.1
Assigned To: Paul Gier
Petr Kremensky
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 04:36 EDT by Miroslav Novak
Modified: 2015-02-20 06:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:29:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Novak 2013-08-16 04:36:01 EDT
Description of problem:

In console log there is HornetQ version 2.3.5.Final:
09:45:23,920 INFO  [org.hornetq.core.server] (MSC service thread 1-5) HQ221001: HornetQ Server version 2.3.5.Final (Monster Bee, 123) [ce9bd290-0647-11e3-ba63-8d680f7503b8] 

but in "hornetq" module ther are jars:

hornetq-commons-2.3.4.Final-redhat-1.jar
hornetq-core-client-2.3.4.Final-redhat-1.jar
hornetq-jms-client-2.3.4.Final-redhat-1.jar
hornetq-jms-server-2.3.4.Final-redhat-1.jar
hornetq-journal-2.3.4.Final-redhat-1.jar
hornetq-server-2.3.4.Final-redhat-1.jar

which are built from HornetQ tag "HornetQ_2_3_4_Final".

There is not tag HornetQ_2_3_5_Final in hornetq project [1] at this moment.

[1] https://github.com/hornetq/hornetq
Comment 1 Miroslav Novak 2013-08-16 04:45:47 EDT
This issue was hit in EAP 6.1.1.ER6 but not in ER4 (ER5 rejected). Adding "Regression" keyword.
Comment 3 Clebert Suconic 2013-08-20 11:48:14 EDT
I would take this more seriously...


I just did a build using the EAP tag, and when I look at the modules, I see:


./modules/system/layers/base/org/hornetq/main/hornetq-commons-2.3.5.Final.jar
./modules/system/layers/base/org/hornetq/main/hornetq-core-client-2.3.5.Final.jar
./modules/system/layers/base/org/hornetq/main/hornetq-jms-client-2.3.5.Final.jar
./modules/system/layers/base/org/hornetq/main/hornetq-jms-server-2.3.5.Final.jar
./modules/system/layers/base/org/hornetq/main/hornetq-journal-2.3.5.Final.jar
./modules/system/layers/base/org/hornetq/main/hornetq-server-2.3.5.Final.jar
./modules/system/layers/base/org/hornetq/ra/main/hornetq-ra-2.3.5.Final.jar



I bet there was a build issue and this took the previous version. 

It seems some sort of mistake was made during the building and that kind of thing will differ between build and the actual tag.


I have no control over this since I don't own the build, you will have to check upstream on what happened.
Comment 4 Clebert Suconic 2013-08-20 11:52:56 EDT
I just did a fresh clone out of github:


git clone git://github.com/hornetq/hornetq.git hornetq-upstream
cd hornetq-upstream
git tag | grep 2.3.5


>>> HornetQ_2_3_5_Final


so, the tag is there!
Comment 6 Paul Gier 2013-08-20 12:28:20 EDT
This is caused by the hard-coded version properties in the root POM.
Our build system automatically appends -redhat-X onto the end of the versions in the pom, however, it's not able to automatically update these properties.

For ER7 we can just hard code the correct version suffix, and then Clebert can try to find a way to automatically get the suffix from the pom version for the next release.
Comment 7 Paul Gier 2013-08-20 12:33:30 EDT
Upstream hornetq issue to track longer term fix: https://issues.jboss.org/browse/HORNETQ-1247
Comment 8 Miroslav Novak 2013-08-21 03:00:27 EDT
Good to see this fixed in EAP 6.1.1.ER7. Thanks!

Note You need to log in before you can comment on or make changes to this bug.