Bug 997926 - Error message when the user aleady exists should say user already exists
Error message when the user aleady exists should say user already exists
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.2 Beta
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 10:13 EDT by Preethi Thomas
Modified: 2015-02-28 16:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-28 16:57:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 366 None None None Never

  None (edit)
Description Preethi Thomas 2013-08-16 10:13:24 EDT
Description of problem:

If a user with the same login exist the message says  "A resource with the ID "user1" already exists." It would be better to say " A user with login User1 already exists" because for permissions, the term resource is used in different context

 
[root@hp-dl380pgen8-02-vm-16 ~]# pulp-admin auth permission
Usage: pulp-admin [SUB_SECTION, ..] COMMAND
Description: manage granting, revoking and listing permissions for resources

Available Commands:
  grant  - grants resource permissions to given user or given role
  list   - lists permissions for a particular resource
  revoke - revokes resource permissions from given user or given role
[root@hp-dl380pgen8-02-vm-16 ~]# 


Version-Release number of selected component (if applicable):

[root@hp-dl380pgen8-02-vm-16 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.26.beta.fc19.noarch

How reproducible:


Steps to Reproduce:
1. create a user
2. try to create the same user again
3.

Actual results:
[root@hp-dl380pgen8-02-vm-16 ~]# pulp-admin auth user create --login user1 --password redhat
A resource with the ID "user1" already exists.



Expected results:


Additional info:
Comment 1 Chris Duryee 2014-11-11 16:42:35 EST
This is still outstanding as of 2.4.3.
Comment 2 Brian Bouterse 2015-02-28 16:57:59 EST
Moved to https://pulp.plan.io/issues/366

Note You need to log in before you can comment on or make changes to this bug.