Bug 997930 - HPUX: WARN: The currently defined selector provider class (sun.nio.ch.PollSelectorProvider) is not supported for use with XNIO
HPUX: WARN: The currently defined selector provider class (sun.nio.ch.PollSel...
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Other (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jason Greene
Jitka Kozana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 10:27 EDT by Jitka Kozana
Modified: 2014-10-25 08:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 07:22:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jitka Kozana 2013-08-16 10:27:03 EDT
EAP 6.1.1.ER6 (but was seen also in ER5), HPUX platform only.

The following warning is logged in server logs on every server startup.

00:50:45,162 WARN  [org.xnio.nio] (MSC service thread 1-26) The currently defined selector provider class (sun.nio.ch.PollSelectorProvider) is not supported for use with XNIO

It was seen for every combination of HPUX jdk's and EAP's configuration. 

Note: I did not know which component should I choose, therefore the "Other". If this should be filed for another component, please change the component field accordingly. Thank you.

Link to the server.log:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-6x-manu-acceptance-multinode-startup-different-ports-hpux/jdk=jdk16_hpux,label=hpux11v3/7/artifact/target/manu-reports/units/manu.testsuite.eap._6.acceptance.multinodeStartup.MultinodeStartupDifferentPorts/as0-standalone-full.xml.0.log
Comment 1 Rostislav Svoboda 2014-03-04 07:22:23 EST
JDK 6 is not supported on HPUX, the failure wasn't seen on JDK 7 on HPUX with EAP 6.3.0 DR0 and DR1.
Comment 2 Jitka Kozana 2014-05-22 03:56:15 EDT
JKD6 is not supported anymore, closing.

Note You need to log in before you can comment on or make changes to this bug.