Bug 997950 - [abrt] WARNING: at drivers/iommu/intel_irq_remapping.c:533 intel_irq_remapping_supported+0x35/0x78()
[abrt] WARNING: at drivers/iommu/intel_irq_remapping.c:533 intel_irq_remappin...
Status: CLOSED DUPLICATE of bug 982153
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:5b7ade9c627f7c882e2ea92ae52...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 11:26 EDT by Steve Ardern
Modified: 2013-08-20 08:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 08:56:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (71.17 KB, text/plain)
2013-08-16 11:26 EDT, Steve Ardern
no flags Details

  None (edit)
Description Steve Ardern 2013-08-16 11:26:46 EDT
Description of problem:
Ran 'yum update' - part of the new packages included the latest kernel 3.10.6:

Install kernel-3.10.6-200.fc19.x86_64                    @updates

Rebooted machine - up popped alert.

(Based on backtrace info, I am going to install the latest BIOS image (A17) for this machine.

Additional info:
reporter:       libreport-2.1.6
WARNING: at drivers/iommu/intel_irq_remapping.c:533 intel_irq_remapping_supported+0x35/0x78()
This system BIOS has enabled interrupt remapping
on a chipset that contains an erratum making that
feature unstable.  To maintain system stability
interrupt remapping is being disabled.  Please
contact your BIOS vendor for an update
Modules linked in:
CPU: 0 PID: 1 Comm: swapper/0 Not tainted 3.10.6-200.fc19.x86_64 #1
Hardware name: Dell Inc. Precision WorkStation T3500  /09KPNV, BIOS A16 07/06/2012
 000000000000000b ffff8803060b7d88 ffffffff81638f6b ffff8803060b7dc0
 ffffffff8105c211 0000000000000000 0000000000000246 00000000ffffffff
 0000000000000080 0000000000000000 ffff8803060b7e20 ffffffff8105c2c4
Call Trace:
 [<ffffffff81638f6b>] dump_stack+0x19/0x1b
 [<ffffffff8105c211>] warn_slowpath_common+0x61/0x80
 [<ffffffff8105c2c4>] warn_slowpath_fmt_taint+0x44/0x50
 [<ffffffff81036ff0>] ? ioapic_read_entry+0x40/0x50
 [<ffffffff81d5a0f5>] intel_irq_remapping_supported+0x35/0x78
 [<ffffffff81512d6b>] irq_remapping_supported+0x2b/0x30
 [<ffffffff81d1d23c>] enable_IR+0xa/0x60
 [<ffffffff81d1d491>] enable_IR_x2apic+0x8d/0x13f
 [<ffffffff81d1f2a6>] default_setup_apic_routing+0x11/0x69
 [<ffffffff81d1b1b0>] native_smp_prepare_cpus+0x2c0/0x3c2
 [<ffffffff81d0afa2>] kernel_init_freeable+0xba/0x1fa
 [<ffffffff81623110>] ? rest_init+0x80/0x80
 [<ffffffff8162311e>] kernel_init+0xe/0x190
 [<ffffffff816474ac>] ret_from_fork+0x7c/0xb0
 [<ffffffff81623110>] ? rest_init+0x80/0x80
Comment 1 Steve Ardern 2013-08-16 11:26:52 EDT
Created attachment 787341 [details]
File: dmesg
Comment 2 Yann Droneaud 2013-08-20 06:32:15 EDT
Different vendor, same problem:

------------[ cut here ]------------
WARNING: at drivers/iommu/intel_irq_remapping.c:533 intel_irq_remapping_supported+0x35/0x78()
This system BIOS has enabled interrupt remapping
on a chipset that contains an erratum making that
feature unstable.  To maintain system stability
interrupt remapping is being disabled.  Please
contact your BIOS vendor for an update
Modules linked in:
CPU: 0 PID: 1 Comm: swapper/0 Not tainted 3.10.7-200.fc19.x86_64 #1
Hardware name: Hewlett-Packard HP Z800 Workstation/0AECh, BIOS 786G5 v03.54 11/02/2011
 000000000000000b ffff880111687d88 ffffffff816390fb ffff880111687dc0
  ffffffff8105c211 0000000000000000 0000000000000246 00000000ffffffff
 0000000000000080 0000000000000000 ffff880111687e20 ffffffff8105c2c4
Call Trace:
 [<ffffffff816390fb>] dump_stack+0x19/0x1b
 [<ffffffff8105c211>] warn_slowpath_common+0x61/0x80
 [<ffffffff8105c2c4>] warn_slowpath_fmt_taint+0x44/0x50
 [<ffffffff81036ff0>] ? ioapic_read_entry+0x40/0x50
 [<ffffffff81d5a0f5>] intel_irq_remapping_supported+0x35/0x78
 [<ffffffff81512efb>] irq_remapping_supported+0x2b/0x30
 [<ffffffff81d1d23c>] enable_IR+0xa/0x60
 [<ffffffff81d1d491>] enable_IR_x2apic+0x8d/0x13f
 [<ffffffff81d1f2a6>] default_setup_apic_routing+0x11/0x69
 [<ffffffff81d1b1b0>] native_smp_prepare_cpus+0x2c0/0x3c2
 [<ffffffff81d0afa2>] kernel_init_freeable+0xba/0x1fa
 [<ffffffff816232a0>] ? rest_init+0x80/0x80
 [<ffffffff816232ae>] kernel_init+0xe/0x190
 [<ffffffff8164766c>] ret_from_fork+0x7c/0xb0
 [<ffffffff816232a0>] ? rest_init+0x80/0x80
---[ end trace 445f4361d713967b ]---
Comment 3 Josh Boyer 2013-08-20 08:56:03 EDT

*** This bug has been marked as a duplicate of bug 982153 ***

Note You need to log in before you can comment on or make changes to this bug.