Bug 997971 - Panic in selinux routine sidtab_context_to_sid() during RHEV-H upgrade.
Panic in selinux routine sidtab_context_to_sid() during RHEV-H upgrade.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
x86_64 Linux
unspecified Severity medium
: rc
: 6.5
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 12:07 EDT by Gordon Watson
Modified: 2013-08-30 09:25 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 09:25:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 456313 None None None Never
Red Hat Knowledge Base (Solution) 457343 None None None Never

  None (edit)
Description Gordon Watson 2013-08-16 12:07:19 EDT
Description of problem:

A customer was upgrading from RHEV-H '20130501.0.el6_4' to '20130709.0.el6_4' from CD/DVD. The upgrade process completed, but during the subsequent reboot the system panic'ed in sidtab_context_to_sid(), which is an selinux routine.

It appears that the customer had tried to disable selinux some time previously by modifying '/etc/selinux/config' with "SELINUX=disabled" and then persisting this file and rebooting. After the reboot I believe that they probably then set selinux into permissive mode.


Version-Release number of selected component (if applicable):

RHEV-H '20130709.0.el6_4' 


How reproducible:

I tried to reproduce it here, but to no avail.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 8 Eric Paris 2013-08-28 14:31:08 EDT
I've never seen anything like it...

Without a reproducer or even maybe a crash drump, I'm going to have to go with solar flares.  We haven't touched that code in many many years and I've never seen a similar panic...
Comment 11 Mike Burns 2013-08-30 09:25:45 EDT
Closing as worksforme since we cannot reproduce the issue and based on responses from selinux team.

Note You need to log in before you can comment on or make changes to this bug.