Bug 997991 - inconsistent/incorrect availablility status for icon
inconsistent/incorrect availablility status for icon
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 13:33 EDT by Alan Santos
Modified: 2015-12-21 09:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 09:03:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Santos 2013-08-16 13:33:57 EDT
Description of problem:

The resource icon in the inventory detail screen shows (the larger version of what's in the tree) doesn't update availability badge as the 'availability' icon does on the top right. 

 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1) Navigate to platform and view detail page
2) Kill agent
3) green check changes to down/unknown
4) resource icon (e.g. the 'monitor') stays as is (no badge)
5) manually refresh page 
6) resource icon (e.g. the 'monitor') includes a red badge
7) restart agent 
8) unknown/down icon changes to  green check
9) resource icon (the 'monitor') keeps red badge


Expected results:

resource icon should be updated with availability badge to match the availability indicator

Note You need to log in before you can comment on or make changes to this bug.